Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2091 closed patch (invalid)

Signal Strength displays as 0%

Reported by: bradley.kite@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: low Keywords: signal strength
Cc: Ticket locked: no

Description

Hi All,

With my Conexant-based Nova-T card, tzap shows a signal strength value but in mythtv this was always coming out at 0%.

This may be related to #616, as I'm aware that drivers dont specify the units used to measure signal strength, and MythTV then does some post-processing to try and convert this to a percentage, which was failing because I think my card returns the signal strength as a percentage already (~ 64 "units" which I'm guessing is a percentage - or could this be the raw value in Db?)

The patch attached fixes this so that if there is a signal strength more than zero returned from the driver, but normalisation (converting it into a percentage) converts it to zero, then to use the raw value instead.

MythTV is a great system btw, I cant wait till after the SoC branches are complete!

Attachments (1)

conexant_signal_strength.diff (1.1 KB) - added by bradley.kite@… 13 years ago.
patch to fix problem of 0% signal strength being displayed on Conexant-based chips

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by bradley.kite@…

patch to fix problem of 0% signal strength being displayed on Conexant-based chips

comment:1 Changed 13 years ago by danielk

Resolution: invalid
Status: newclosed

Bradley, first thanks for figuring out the problem and making a patch.

I'm closing this though, as it should be fixed in the driver, the driver should normalize it's signal value to use the range 0..65535. The range was probably not well defined when the driver was written, so it isn't the driver writer's fault.

BTW This "signal" value is not the same as the signal to noise ratio ("SNR" or "S/N"), which is the value we report after the "signal" value. The SNR is still not defined in the DVB API.

comment:2 Changed 13 years ago by Janne <janne-mythtv@…>

As far as I understand the code correctly upgrading to 0.19 should also fix your problem. Bug reports against older releases (as in "not the actual release") are pretty useless since nobody will fix it especially if it's fixed in the later release.

comment:3 Changed 13 years ago by bradley.kite@…

Version: 0.18head

Hi Jane,

My patch is actually against SVN 10624. I believe I left the version field blank when creating the ticket and it seems to have defaulted it to version 0.18.

I'm create a patch against the actual driver to fix the problem, and audit the front-ends too while I'm at it. Mostly it would seem that the values are fetched from an 8-bit register any way, which some front-ends shift by 8 bits while others dont.

Regards -- Brad.

comment:4 Changed 13 years ago by Janne <janne-mythtv@…>

I patched one of my frontends to return 0 as signal and I can't reproduce the problem. Tuning works as before but signal is reported as 0%.

Note: See TracTickets for help on using tickets.