Opened 13 years ago

Closed 13 years ago

#2093 closed defect (invalid)

mythbackend crash after recording (making the preview)

Reported by: smalenfant@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.19
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After some recording, mostly on NBC (1080i), mythbackend crashes on making the preview thumbnails. I'm attaching the log that I recorded from "mythbackend -v all" and the backtrace. Please tell me if you need more info. I can include or send a cutout of the source file that creates the problem.

Other problem I have to that seems to be realted to this one is the impossibility or marking commercial in some files where mythfrontend crashes. Also mythtranscode would fail (probably crash the same way) when transcoding (cutting commercials).

I'm marking this ticket as minor because I can still watch my files using mplayer/vlc without any problem (but not with mythtv). You can work around by creating a cron job that check that mythbackend is up and restart the process, then copy an .nuv.png from an other recording so the backend doesn't crash again copying the file. But I truly think it should be major :)

This problem is present in both 0.19 and in the head (I'm using 10625 right now).

Attachments (2)

backtrace.txt (15.5 KB) - added by smalenfant@… 13 years ago.
Backtrace
mythbackend.log (127.2 KB) - added by smalenfant@… 13 years ago.
The mythbackend -v all debug

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by smalenfant@…

Attachment: backtrace.txt added

Backtrace

Changed 13 years ago by smalenfant@…

Attachment: mythbackend.log added

The mythbackend -v all debug

comment:1 Changed 13 years ago by smalenfant@…

I have the file on my web server, I'll send the link on demand. 88326144 Jul 24 21:22 1111_20060615220000.mpg

comment:2 Changed 13 years ago by danielk

Resolution: invalid
Status: newclosed

Please see the TicketHowTo, the backtrace is not useful as is. Also, this is probably an ffmpeg problem. You might want to try to reproduce this problem on playback using ffmpeg and reporting the problem directly to the ffmpeg mailing list. You will need to cut down the recording to a small 30 second or so clip that causes the segfault for either MythTV or ffmpeg developers to look at the problem.

Note: See TracTickets for help on using tickets.