Opened 13 years ago

Closed 13 years ago

#2099 closed defect (fixed)

RetuneMonitor generates significant load with DVB cards without hardware i2c support

Reported by: yeasah@… Owned by: Stuart Auchterlonie
Priority: minor Milestone: 0.20
Component: dvb Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Janne Grunau's original description of the problem:

The cause is the FE_READ_STATUS ioctl in RetuneMonitor?. It blocks for approximately 10ms on cards with a cx88 or bt8xx pci bridge and the pluto2 device. These devices have no hardware i2c support. For the cx88 it's just not implemented yet. They use i2c bit banging instead.

This wouldn't be a problem if the signalmonitor is only for tuning checks before channel changes. But it isn't that good for the active eitsccanner.

I believe it's time for the !FE_CAN_RECOVER retunes to go away (such a short life!) -- the only DVB driver which required this has since been fixed, and since the rotor completion implies a retune anyway, it only helps if you have the older broken driver AND you have an incorrect rotor configuration (i.e. the angular speed set in the DB is higher than the motor actually moves)

I'm particularly concerned that the retunes might conceal problems with the new diseqc code not being reliable (though it could conceal a wide variety of tuning problems too), so I'm actually rather keen to get it out of there.

Attaching a patch that removes the periodic retune stuff from the dvb signal monitor and channel objects.

Attachments (1)

remove-norecover-retunes.patch (2.9 KB) - added by yeasah@… 13 years ago.

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by yeasah@…

comment:1 Changed 13 years ago by Stuart Auchterlonie

Milestone: 0.20
Owner: changed from danielk to Stuart Auchterlonie
Version: head

This patch successfully removes the 10% loading per card during the eit active scan.

comment:2 Changed 13 years ago by Stuart Auchterlonie

Resolution: fixed
Status: newclosed

(In [10643]) Closes #2099. Removes ReTuneMonitor?

ReTuneMonitor? was causing 10% cpu load per card during eit active scanning. This removes the ReTuneMonitor? as it is no longer needed.

It was only useful iff you had a specific card and using a buggy driver and had your configuration incorrect. Configurations can be fixed and the driver bug has also been fixed.

Note: See TracTickets for help on using tickets.