Opened 13 years ago

Closed 12 years ago

#2123 closed task (fixed)

mythtv-vid: Playback profiles editor can not yet save changes

Reported by: masterclc@… Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: low Keywords: MythTV-VID
Cc: Ticket locked: no

Description

Good afternoon!

I'm trying to troubleshoot the MythTV-VID branch to get myth to display 1080i content on my SP13000 with a Via CN400 chipset. I've sucessfully compiled it, and was able to link it directly against my libviaXvMCPro library for XvMC. However, now when I try to change the CPU profiles (any of them) to use the Via XvMC output, none of my changes are saved. I checked the database and indeed, they are the original values:

mysql> select data from displayprofiles;
+-------------+
| data        |
+-------------+
| 1           |
| > 0 0       |
| ffmpeg      |
| xv-blit     |
| softblend   |
| bobdeint    |
| linearblend |
|             |
| 1           |
| <= 720 576  |
| > 0 0       |
| ffmpeg      |
| xv-blit     |
| softblend   |
| bobdeint    |
| linearblend |
|             |
| 2           |
| <= 1280 720 |
| > 720 576   |
| xvmc        |
| xvmc-blit   |
| opengl      |
| bobdeint    |
| onefield    |
|             |
| 3           |
| <= 1280 720 |
| > 720 576   |
| libmpeg2    |
| xv-blit     |
| softblend   |
| bobdeint    |
| onefield    |
|             |
| 4           |
| > 0 0       |
| xvmc        |
| xvmc-blit   |
| ia44blend   |
| bobdeint    |
| onefield    |
|             |
| 5           |
| > 0 0       |
| libmpeg2    |
| xv-blit     |
| chromakey   |
| bobdeint    |
| onefield    |
|             |
| 1           |
| <= 720 576  |
| > 0 0       |
| ivtv        |
| ivtv        |
| ivtv        |
| none        |
| none        |
|             |
| 2           |
| <= 720 576  |
| > 0 0       |
| xvmc        |
| xvmc-blit   |
| ia44blend   |
| bobdeint    |
| onefield    |
|             |
| 3           |
| <= 1280 720 |
| > 720 576   |
| xvmc        |
| xvmc-blit   |
| ia44blend   |
| bobdeint    |
| onefield    |
|             |
| 4           |
| > 0 0       |
| xvmc        |
| xvmc-blit   |
| ia44blend   |
| bobdeint    |
| onefield    |
|             |
| 5           |
| > 0 0       |
| libmpeg2    |
| xv-blit     |
| chromakey   |
| none        |
| none        |
|             |
+-------------+
94 rows in set (0.00 sec)

This is *after* I made the change in the frontend. I'll have to brush up on mysql syntax and see if I can manually change those entries to continue testing. Hopefully though, we can get it to actually accept the changes made in the frontend?

Thanks!

-Chad

Attachments (4)

mythfrontend.log.gz (3.4 KB) - added by masterclc@… 13 years ago.
mythfrontend -v playback
Xorg.0.log.gz (6.5 KB) - added by masterclc@… 13 years ago.
Xorg.0.log to verify XvMC is working
fix_for_broken_recording_profiles.diff (497 bytes) - added by skamithi 13 years ago.
while working on pip stuff, i noticed [11509] broke recording profiles. i'm not fluent with how the settings.cpp works, but the attached fix resolved the issue for me. problem was that mythtv was returning profile ID 0 (therefore asked to create a new profile) regardless of which recording profile I chose.
fix_broken_display_profiles.diff (855 bytes) - added by skamithi 12 years ago.
when you select a option from the transcombosetting, it sets the current value to the current label. this causes the label to be added to the database instead of the value. potential fix find the value attached to the label and uses that instead.

Download all attachments as: .zip

Change History (23)

comment:1 Changed 13 years ago by danielk

Owner: changed from Isaac Richards to danielk

Please read the TicketHowTo, especially the portion about assigning tickets to the right developer. If all the checkins on a branch are from one programmer, that's the one to assign the ticket to :)

comment:2 Changed 13 years ago by masterclc@…

My appologies. Will read the how-to, I wasn't sure if we assigned the tickets, or if we just report them and then the respective 'dev' assigned them to themselves.

Thanks!

-Chad

comment:3 Changed 13 years ago by masterclc@…

I was able to edit the entries in the database, but it continues to refuse to use XvMC. I'll be happy to attach any files needed, and I figure a good start would be 'mythfrontend -v playback', so I'll attach it as well as Xorg.0.log both gzipped.

Thanks!

-Chad

Changed 13 years ago by masterclc@…

Attachment: mythfrontend.log.gz added

mythfrontend -v playback

Changed 13 years ago by masterclc@…

Attachment: Xorg.0.log.gz added

Xorg.0.log to verify XvMC is working

comment:4 Changed 13 years ago by anonymous

Is there any change on this? I am trying to test out MythTV-SVN on an SP13000 as well as a Commell 667-T. Both use the CN400 chipset.

comment:5 Changed 13 years ago by masterclc@…

It seems nothing has changed on this. Is there a workaround to use in the meantime? I've got a couple of machines that are just paper weights, expensive paper weights. It would sure be nice to be able to use them. The 1080i recordings seem to outnumber the 720p, so I can't even watch half of my recordings in the current state of MythTV unless I manually run mplayer on each one.

Thanks for any updates.

-Chad

comment:6 Changed 13 years ago by masterclc@…

This really makes testing the VID branch extremely hard. However, I went into the database and changed the profiles to xvmc-vld on every single one and now it uses it during playback. Using the profile 'changes' within mythfrontend would really make testing much easier...

-Chad

comment:7 Changed 13 years ago by masterclc@…

Hacking the db to remove EVERY profile save 1 still doesn't get xvmc-vld used. Are the profiles even doing anything? Any hints? Any at all...

-Chad

comment:8 Changed 13 years ago by danielk

Summary: CPU--/CPU+/CPU++ Profiles don't accept any changesPlayback profiles editor can not yet save changes
Type: defecttask

chad, it iurns out this is not a bug. I just haven't gotten around to implementing saving from the playback profile setup UI. I added some better error reporting in [11498], so that you can see why your manually inserted video playback profile failed.

comment:9 Changed 13 years ago by danielk

Summary: Playback profiles editor can not yet save changesmythtv-vid: Playback profiles editor can not yet save changes

comment:10 Changed 13 years ago by danielk

(In [11501]) Refs #2123. This changeset allows saving edits to pre-existing display profile entries in the Playback Profiles Editor in mythtv-vid.

You can not yet add profiles, add profile entries, delete profiles or delete profile entries; this only allows you to edit existing entries in one of the three existing profiles.

comment:11 Changed 13 years ago by danielk

(In [11504]) Refs #2123, refs #2287. Allows deleting display profile entries in the Playback Profiles Editor in mythtv-vid.

comment:12 Changed 13 years ago by danielk

(In [11505]) Refs #2123, refs #2287. Updates the display profile entry labels after you edit an entry in the Playback Profiles Editor in mythtv-vid.

comment:13 Changed 13 years ago by danielk

(In [11506]) Refs #2123, refs #2287. Allows adding display profile entries in the Playback Profiles Editor in mythtv-vid.

comment:14 Changed 13 years ago by danielk

(In [11509]) Refs #2123, refs #2287. Allows adding and deleting display profile groups in the Playback Profiles Editor in mythtv-vid.

There are still bugs in this code, please don't open new tickets on them until #2123 is closed; mostly the bugs have to do with screens not repainting appropriately or initial values being screewy, so they can be worked around.

Changed 13 years ago by skamithi

while working on pip stuff, i noticed [11509] broke recording profiles. i'm not fluent with how the settings.cpp works, but the attached fix resolved the issue for me. problem was that mythtv was returning profile ID 0 (therefore asked to create a new profile) regardless of which recording profile I chose.

comment:15 Changed 13 years ago by danielk

(In [11674]) Refs #2123. Refs #2287. Fixes bug introduced in [11509] which broke recording profiles with patch from skamithi.

Changed 12 years ago by skamithi

when you select a option from the transcombosetting, it sets the current value to the current label. this causes the label to be added to the database instead of the value. potential fix find the value attached to the label and uses that instead.

comment:16 Changed 12 years ago by danielk

(In [12677]) Refs #2123. Fixes bug with display profile editor where it would save the descriptive label of a combobox element rather than the value.

This was due to an earlier sync with svn head which made the combobox values read/write rather than read only.

comment:17 Changed 12 years ago by danielk

(In [12683]) Refs #2123. Fixes priority setting in playback profile editor.

comment:18 Changed 12 years ago by danielk

(In [12684]) Refs #2123. Removes debugging statement left in when I committed [12683].

comment:19 Changed 12 years ago by danielk

Resolution: fixed
Status: newclosed

(In [12685]) Fixes #2123. Fixes the initialization of the profile editor items in mythtv-vid branch.

Note: See TracTickets for help on using tickets.