Opened 13 years ago

Closed 13 years ago

#2133 closed defect (wontfix)

Scheduled recording aborted directly when watching LiveTV on same tuner

Reported by: erland_i@… Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

MythTV was playing Live TV on another channel on the same tuner when a the time for a scheduled recording occured. I was not at the TV at the moment so I don't know if any question popped up requesting to change channel. Anyway, the problem is that the channel was changed correctly to the one which was going to be recordet, but the scheduled recording was aborted directly and the recording is marked as "recorded" when looking in the recording history as if it succeeded.

I am running SVN 10664 and I have seen the same problem one time earlier with the same SVN version.

I will attach the mythbackend log, I was watching "Friidrotts-EM 2006: channel 1002" before and the scheduled recording was "Bad Girls: channel 1083".

Attachments (1)

backend.log (4.5 KB) - added by erland_i@… 13 years ago.
Mythbackend log from when the problem occured.

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by erland_i@…

Attachment: backend.log added

Mythbackend log from when the problem occured.

comment:1 Changed 13 years ago by danielk

Milestone: 0.20
Owner: changed from Isaac Richards to danielk

By "aborted directly" you mean you aborted the recording manually?

comment:2 Changed 13 years ago by erland_i@…

This happend:

  1. I was watching another channel on the same tuner
  2. The time for a scheduled recording occured and MythTV changed to the channel that should be recorded. I didn't do anything at this time since I wasn't in the room.
  3. MythTV stopped the scheduled recording directly and its shows it as "recorded" in the history with a size of 0 minutes.


So I didn't abort the recording manually, MythTV decided to stop the recording automatically directly after it had been started for some reason.

comment:3 Changed 13 years ago by danielk

Resolution: wontfix
Status: newclosed

Hmm, it looks like the channel was encrypted and you're missing the decryption key. The dvb signal monitor should detect this, but no one has written the code to check it so until implements the feature this won't be fixed.

If you know this channel is in fact never not encrypted, or you do have the key, please attach a backend log with the "-v record,channel,siparser" logging options when you repeat this. You can schedule a manual recording so you don't need to wait for the next program to start on the problem channel.

Note: See TracTickets for help on using tickets.