Opened 13 years ago

Closed 13 years ago

#2141 closed defect (fixed)

mythfrontend becomes unusable when trying to watch a dvb channel with encryption without the CAM

Reported by: vartiait@… Owned by: Isaac Richards
Priority: minor Milestone: 0.20
Component: dvb Version: 0.19
Severity: medium Keywords: mythfrontend dvb encryption
Cc: Ticket locked: no

Description

When one tries to watch a channel with encryption by accident without having the CAM or cabability of decrypting the stream in general mythfrontend does something for a while and then reports that channel can not be watched and after pressing the enter it returns to the main menu. The problem is that if one tries to watch liveTV again mythfrontend remembers the last channel which in this case is the encrypted channel and the same thing described above happens again without a possibility to change to a unencrypted channel.

Of course this can be prevented by not allowing encrypted channels to be added to the channel list while scanning but at least here in Finland there is some channels which mythtv interprets as encrypted channels even though they are not and some channels are unencrypted when broadcasted in analog network but encrypted when broadcasted in digital so confusion can hapen?

Change History (1)

comment:1 Changed 13 years ago by Janne <janne-mythtv@…>

Component: mythtvdvb
Milestone: 0.20
Resolution: fixed
Status: newclosed

It is fixed in snv trunk and I doubt that anyone is willing to apply patches for 0.19-fixes let alone backport fixes. So I close the ticket.

Note: See TracTickets for help on using tickets.