Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2145 closed defect (invalid)

mythtranscode hangs

Reported by: dhighley@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.19
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have been using nuvexport-dvd taking all the defaults. Only modification configuratin was to turn on commercial cutting. I'm using the svn myth release-0.19-fixes, This has worked for several months on a Fedora core 5 system. I have checked the mythbackend log file and the /var/log/messages file and find no errors. The mythbackend log enters two lines after the last prompt: 2006-08-09 20:00:23.141 MainServer::HandleAnnounce? Monitor 2006-08-09 20:00:23.148 adding: redwood as a client (events: 0)

The nuvexport-dvd output is: You have chosen to export 1 episode:

  1. Mrs. Doubtfire: (8/8, 8:00 PM) 720x480 RJPG (4:3) Estranged from his wife (Sally Field), an out-of-work actor (Robin Williams) masquerades as a nanny to be with his children.
  • Separate multiple episodes with spaces, or ranges with '-'
  1. Continue
  2. Choose another show
  3. Quit

Choose a function, or episode(s) to remove: c Where would you like to export the files to? . Enable Myth cutlist? [Yes] Enable noise reduction (slower, but better results)? [Yes] Enable deinterlacing? [Yes] Crop broadcast overscan border (0-5%) ? [2] Audio bitrate? [384] Maximum video bitrate for VBR? [6000] VBR quality/quantisation (1-31)? [5]

Now encoding: Mrs. Doubtfire: Untitled Encode started: Wed Aug 9 19:57:51 2006 2006-08-09 19:57:51.361 Using runtime prefix = /usr/local 2006-08-09 19:57:51.380 New DB connection, total: 1 2006-08-09 19:57:51.384 Connected to database 'mythconverg' at host: localhost 2006-08-09 19:57:51.388 New DB connection, total: 2 Waiting for mythtranscode to set up the fifos. Starting ffmpeg. processed: 0 of 322866 frames (0.00%), 0.00 fps

Change History (3)

comment:1 Changed 13 years ago by danielk

Priority: criticalminor
Resolution: invalid
Severity: highmedium
Status: newclosed
Summary: mythtranscode hangs version 0.19mythtranscode hangs

Please test against SVN head. Provide a backtrace after it hangs and a short clip (<30 seconds) of a video that causes the problem (you can use conventional file splitting commands). See the TicketHowTo for links to how to create a backtrace, etc.

comment:2 Changed 13 years ago by anonymous

I grabbed the head, svn co http://svn.mythtv.org/svn/trunk/mythtv, for all three parts built and re-tried running nuvexport-dvd. Same results. What other information will help in determining what is broken?

comment:3 Changed 13 years ago by dhighley@…

It is working now. I needed to do an svn update of nuvexport and get it in sync with myth. Did not think about the coupling between the two applications.

Note: See TracTickets for help on using tickets.