Opened 13 years ago

Closed 13 years ago

#2153 closed defect (invalid)

Channel.cpp: dfield messes up picture settings.

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: low Keywords: channel.cpp
Cc: Ticket locked: no

Description

I have just upgraded my svn copy and found that my Composite input didn't work anymore. I discovered the cause was the hue being set to 0 and the contrast being very low. I noticed that my values for picture setting were having dfield aded to them before being sent to the card. The values for dfield were 32768, meaning that my hue (normally set at 50%) became 0, leading to no picture.

I'm not sure if dfield was just added, or if I am just noticing it now. I set the value of dfield to 0 and rebuilt and there was no problems, it all worked well.

Thankyou -Ben

Attachments (1)

2153-test.patch (889 bytes) - added by danielk 13 years ago.
testing patch

Download all attachments as: .zip

Change History (9)

comment:1 Changed 13 years ago by danielk

Milestone: 0.20
Owner: changed from Isaac Richards to danielk
Severity: mediumlow

What version were you upgrading from?

Had you applied any patches or used another tree which might have caused you to miss a DB update?

comment:2 Changed 13 years ago by anonymous

Keywords: channel.cpp added; channnel.cpp removed

I was using a svn live ebuild (Probably 3-4 months old), but then just re-downloaded the entire tree and built from there.

So, no patches. But I haven't applied any database updates manually.

To my knowledge it has always been head.

comment:3 Changed 13 years ago by danielk

Ben, some questions:

What hardware are you using? Had you ever adjusted the channel's recording hue before?

(if so, any idea what the value was?)

If you do a fresh install with a new DB, does this happen?

dfield is supposed to adjust the default values so that the channel's recording picture attribute can be 50% and you still get the correct default picture attribute even if the hardware's default is something other than 50%.

BTW Please respond in the mythtv-dev mailing list.

comment:4 in reply to:  3 Changed 13 years ago by anonymous

Replying to danielk:

Sorry, but I'm not sure how to use mailing lists. I kinda know how to post, but not how to link it to this ticket, if that is what I'm supposed to do.

I'm running a DViCO FusionHDTV DVB-T Plus on an AMD64 running Gentoo. I'm updating the kernel now, cause there seems to be some problems recording from the Composite now (tvtime works perfect though)

How do I do a clean install? make uninstall?

Am I doing all the steps? I just follow the "Upgrading to SVN" guide, and use my old init.d files.

As it is, all my channel specific data defaults to 50%, and the card data is 0%. So with the dfield it becomes 100% which then becomes 0% after the bitwise AND.

I have changed the brightness, colour and contrast from defaults. But I havent changed the hue (which is why it was the only one to become 0)

So if you could tell me where to look for how to respond, and how to do a clean install.

comment:5 Changed 13 years ago by danielk

In general a clean install means you wipe/delete your mythconverg database and start over (you should back up the database first) as if you were installing MythTV the first time. But in this case it would just mean deleting the card and channel lineups and recreating these.

The DViCO FusionHDTV DVB-T Plus uses the CX2388x chipset, I wonder if this card might have the same problems as the HD3000 with the Hue... Before you do any of the above can you apply the patch I'll be attaching in a moment and run this SQL:

  update channel set brightness=32768;
  update channel set contrast=32768;
  update channel set colour=32768;
  update channel set hue=32768;
  update capturecard set brightness=32768;
  update capturecard set contrast=32768;
  update capturecard set colour=32768;
  update capturecard set hue=32768;

If your DViCO card has the same characteristics as the HD3000, this should give you approximately the right colors.

Changed 13 years ago by danielk

Attachment: 2153-test.patch added

testing patch

comment:6 in reply to:  5 Changed 13 years ago by anonymous

Replying to danielk: There isn't a "problem" though. I'm not sure what it should be for the other cards, but mine requires hue to be 50% for proper colours. From there it is just math. If channel, card and dfield are all 50%, the sfield + cfield + dfield = 150%. 150% & 100% = 50%.

But the card settings is 0 for my card, thus causing the 0% hue, which results in a bad picture. So perhaps it isn't a bug per se, and just an incompatibility of lazily updating the build and not wanting to redo all the channels. I'm having a much more serious problem now with the Composite, but I'll need to emerge an older version to check if it is the new version, or some problem cause by me not using the mythtv-svn live ebuild (Which now refuses to work...)

Sorry about posting here again, but you didn't mention how to mailing list it.

comment:7 Changed 13 years ago by danielk

If the driver reports that 0% is the default value, and in fact 50% is the correct value, then this is a problem. You can easilly fix it by adjusting the card's hue setting, but the hue should be correct out of the box. Without the tests I requested I can't be sure if this is a a driver problem, MythTV DB upgrade problem, or a MythTV picture adjustment problem.

I'm closing this as invalid until I get the needed logs.

PS To reply to tickets subscribe to the mythtv-dev and mythtv-commits mailing lists. See: http://www.mythtv.org/modules.php?name=MythInfo When someone changes a ticket an email is sent to everyone on the mythtv-commits mailing list, just reply to that message. Since you are presumably not yet subscribed to the commits list, just start a new thread in mythtv-dev with the ticket number in the subject line.

comment:8 Changed 13 years ago by danielk

Resolution: invalid
Status: newclosed

need logs

Note: See TracTickets for help on using tickets.