Opened 13 years ago

Closed 13 years ago

#2162 closed patch (duplicate)

correct osd visibleBounds

Reported by: Janne <janne-mythtv@…> Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

QRect(QPoint(), QPoint()) doesn't create a rectangle of the expected size. QRect(QPoint(0,0), QPoint(1,1)) has width and height 2. It's even documented http://doc.trolltech.com/3.3/qrect.html#QRect-4. Attached patch uses a different constructor.

Scaling with positiv overscan is broken. With attached patch the entire osd is visible even with huge overscan.

Attachments (1)

osd_overscan_fix.diff (882 bytes) - added by Janne <janne-mythtv@…> 13 years ago.

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by Janne <janne-mythtv@…>

Attachment: osd_overscan_fix.diff added

comment:1 Changed 13 years ago by danielk

Milestone: 0.21
Owner: changed from Isaac Richards to danielk

Is this the same ploblem as #1193? Related?

comment:2 Changed 13 years ago by Janne <janne-mythtv@…>

Resolution: duplicate
Status: newclosed

yes, the second part is a duplicate of #1193. The first is related.

Note: See TracTickets for help on using tickets.