Opened 13 years ago

Closed 13 years ago

#2177 closed defect (fixed)

Hidden Channels showing up in Browse Mode

Reported by: michael@… Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Running svn 10761, but have noticed this prev to 10000-ish.

Channels marked as hidden are appearing in the browse mode when watching LiveTV, but do not appear in guide, or considered for recording.

This was broken and fixed nearly a year ago, and seems to have made its way back in again with recent browse mode changes.

Change History (6)

comment:1 Changed 13 years ago by danielk

Milestone: 0.20
Owner: changed from Isaac Richards to danielk
Version: head

comment:2 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

(In [10773]) Fixes #2177. Hides channels hidden in EPG when channel flipping.

I'm not sure if this really is better. I read the arguements from last year and restored the behaviour that was implemented then. However, if you don't like it there is a boolean "skip_non_visible" in channelutil.cpp, if you flip that these channels will only be hidden in the EPG and not in channel flipping.

comment:3 Changed 13 years ago by stuartm

Resolution: fixed
Status: closedreopened

This isn't fixed, non-visible channels are still displayed in browse mode.

comment:4 Changed 13 years ago by anonymous

This is fixed, and working perfectly for me. Unless it got broken after 10891 I would check your hidden settings.

comment:5 Changed 13 years ago by anonymous

Woops, make that svn trunk 10794

comment:6 Changed 13 years ago by stuartm

Resolution: fixed
Status: reopenedclosed

Nevermind, user error.

Note: See TracTickets for help on using tickets.