Opened 13 years ago

Closed 12 years ago

#2184 closed defect (worksforme)

Frontend segfault when viewing Edit Recording Schedule

Reported by: otto at kolsi dot fi Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by cpinkham)

Following ends up with frontend segfault (SVN 10771):

Create a new custom schedule in mythweb:

  • "Record at any time on any channel"
  • Power Search
  • Give some title for the schedule
  • Search Phrase: "program.title LIKE 'Your title%'"
  • Assign a recording to some existing recording group

Once a recording has been recorded based on this schedule, in frontend go to "Recording Options" -> "Edit Recording Schedule" and the frontend segfaults.

I'll attach couple of backtraces that indicate possible problem in programinfo.cpp. I can provide logs, DB info etc. if needed.

Attachments (2)

backtrace1.txt.gz (7.0 KB) - added by otto at kolsi dot fi 13 years ago.
Frontend backtrace
backtrace2.txt.gz (7.0 KB) - added by otto at kolsi dot fi 13 years ago.
Frontend backtrace

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by otto at kolsi dot fi

Attachment: backtrace1.txt.gz added

Frontend backtrace

Changed 13 years ago by otto at kolsi dot fi

Attachment: backtrace2.txt.gz added

Frontend backtrace

comment:1 Changed 13 years ago by otto at kolsi dot fi

I created (with SVN 10935) this type of PowerSearch? recording through the mythfrontend and once the program gets recorded, frontend segfaults every time when viewing "Edit Recording Schedule". So this happens also for recordings that were scheduled using frontend, not only mythweb.

comment:2 Changed 12 years ago by cpinkham

Description: modified (diff)
Resolution: worksforme
Status: newclosed

I'm unable to reproduce this with current SVN. I believe this was fixed somewhere along the way. Please reopen the ticket and attach a new backtrace if you can replicate with current SVN.

Note: See TracTickets for help on using tickets.