Opened 14 years ago

Closed 14 years ago

#2189 closed defect (duplicate)

SVN 10798 failes to compile in videoout_xv.cpp

Reported by: chris [@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi,

I get this error whilst building latest SVN...

distcc[28021] ERROR: compile /root/.ccache/videoout_x.tmp.myth.28002.ii on localhost failed videoout_xv.cpp: In member function 'bool VideoOutputXv::InitXVideo()': videoout_xv.cpp:836: error: 'GUID_I420_PLANAR' was not declared in this scope videoout_xv.cpp:837: error: 'GUID_IYUV_PLANAR' was not declared in this scope videoout_xv.cpp:848: error: 'GUID_YV12_PLANAR' was not declared in this scope videoout_xv.cpp: In member function 'std::vector<unsigned char*, std::allocator<unsigned char*> > VideoOutputXv::CreateShmImages?(uint, bool)': videoout_xv.cpp:1536: error: 'GUID_YV12_PLANAR' was not declared in this scope make[2]: * [videoout_xv.o] Error 1 make[2]: * Waiting for unfinished jobs....

My configure options are ./configure --arch=prescott --prefix=/usr --enable-dvb --dvb-path=/usr/include/dvb --enable-xvmc --enable-opengl-vsync --enable-lirc --enable-dts

I'm using Qt-libs version 3.5 and Xorg 7.1, gcc 4.1.1 with distcc and ccache.

Hope that helps

Chris

Change History (1)

comment:1 Changed 14 years ago by anonymous

Resolution: duplicate
Status: newclosed

Duplicate of #2190 which includes the fix.

Note: See TracTickets for help on using tickets.