Opened 14 years ago

Closed 14 years ago

#222 closed patch (fixed)

DVB: Use TS format by default

Reported by: jesper@… Owned by: danielk
Priority: minor Milestone: 0.19
Component: mythtv Version:
Severity: low Keywords: dvb
Cc: Ticket locked: no

Description

There are several problems with PS recording (e.g. subtitles, XvMC, commflagging...) and the TS recorder seems to generally work better for most people so Myth should use TS by default.

This patch will change everyone's settings to use TS. If there are issues with TS we need to flush them out so they can be fixed.

Also modifies the description for the setting slightly.

Attachments (1)

dvb_recordts.patch (1.8 KB) - added by jesper@… 14 years ago.

Download all attachments as: .zip

Change History (5)

Changed 14 years ago by jesper@…

Attachment: dvb_recordts.patch added

comment:1 Changed 14 years ago by kirwin@…

We already changed it to be the default for new users a while back. The earlier change was also supposed to change it for existing users upon the next database upgrade, but I botched that one. Sorry.

This patch goes a lot further, even changing the setting for existing users, who, presumably like their settings how they are. This I think is a bad idea. Users can change their own settings if they don't like the results. Changing their settings without telling them is bad. In general, I would argue, user settings should only be changed when code changes make it so that those settings are broken or inapplicable.

It also updates the database version in order to forcibly push through the default change in the table. This I had chosen not to do with my patch, but is probably not unreasonable. If it were my decision, I would add the code for the next update, but not update the db version for just a change in the default setting. That way the change would go through whenever someone made a significant enough change to the database to require an upgrade. If I had put the code in the right place in my patch, this would have already happened. Sorry. But if you want to bump the database version, I certainly won't complain.

Keith

comment:2 Changed 14 years ago by jesper@…

Thanks for your comments! I'll try to comment on them:

1) About changing settings without telling. Nothing stops us from telling. There are release notes, commit logs and we could even post a notice on the list when it happens. The problem is that a lot of users obviously have their systems set to use PS without knowing what it means. There has been a steady stream of problems reported on the user list where the fix was to change to TS, so I don't agree that everyone "presumably like their settings how they are". Just trying to be a bit proactive here, but of course that's just my opinion. :)

2) Upping the DB version. AFAIK this is the normal way to push DB changes. It is a one time change and it's doesn't break any compatibility so I don't see a problem with it. BTW, I can't find the change you are talking about. Do you know when it went in?

comment:3 Changed 14 years ago by Isaac Richards

Owner: changed from Isaac Richards to danielk

Daniel, you can decide - I'd be inclined to switch everyone over to TS, myself, and rip out the broken ts->ps junk.

comment:4 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [7059]) Closes #222.

This is Jasper's patch to force the non-broken TS format for DVB recordings.

I'm not going to remove the ts->ps code yet. But I made it harder to re-enable it by commenting out the config option.

We can remove the ts->ps code after 0.19, as we'll probably get all the bug reports on TS playback problems we need after the release.

Note: See TracTickets for help on using tickets.