Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2226 closed defect (fixed)

DVB-S zapping problems

Reported by: lukas.kasprowicz@… Owned by: Stuart Auchterlonie
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I took a look at the tables myself, and it did not look ok, so i removed card, diseqc, ... configuration and recreated it with mythtv-setup.

after this changes it does not work better ;) even worse. Now i am only able to tune to very few channels. e.g. TV Polonia. I have not checked all transports, but the one i mentioned in the email to -dev are not tuneable anymore. The signal on the channels i tested oscilate between 0% and 60%.

I created as wished the db dump of a few tables.

Lukas

Attachments (4)

mythconvergnew.sql.bz2 (11.0 KB) - added by anonymous 13 years ago.
log.txt (52.6 KB) - added by danielk 13 years ago.
log Lukas posted to mailing list
mythtv-diseqc-repeat-option.patch (8.5 KB) - added by yeasah@… 13 years ago.
adds diseqc repeat count option to UI (REQUIRES DB CHANGE NOT IN PATCH)
mythtv-diseqc-multiswitch.patch (9.0 KB) - added by yeasah@… 13 years ago.
take into account polarity and band when considering whether to send committed diseqc messages

Download all attachments as: .zip

Change History (19)

Changed 13 years ago by anonymous

Attachment: mythconvergnew.sql.bz2 added

comment:1 Changed 13 years ago by lueddich@…

I have the same behaviour on my system. I'm not at home, so I got no details, bute pressing 'c' to change the input a few times, waiting ~3 seconds between two attempts, does help SOMETIMES, even when there is only one card using my dvb-s in the machine, the other one is dvb-t... Pro7 can't be tuned over dvb-s by my system even with this 'workaround'... I'll post a table-dump, too, but which tables are needed? Any logs?

Changed 13 years ago by danielk

Attachment: log.txt added

log Lukas posted to mailing list

comment:2 Changed 13 years ago by danielk

Milestone: 0.20
Version: head

Changed 13 years ago by yeasah@…

adds diseqc repeat count option to UI (REQUIRES DB CHANGE NOT IN PATCH)

comment:3 Changed 13 years ago by yeasah@…

I attached a patch to help with flakey diseqc devices, but from the attached log it looks like this particular problem might be unrelated. My interpretation is that the first channel change to channel 898 is successful (which includes a diseqc switching, and is on 12480 V), at least to the point of receiving a correct-looking PAT, but the subsequent channel change to 12003 doesn't seem to get a signal lock. After that it changes back to 898 which is fine.

  • The channel change to 898 involves some diseqc operations (a switch), and it's successful.
  • Neither of the remaining channel changes involve any diseqc operations, since they all use the same switch position.
  • The diseqc switch isn't losing its position, because when channel 898 is tuned again it works fine without being told to switch.
  • The only thing different about the channel that doesn't work (from a tuning perspective) is that it has a different frequency, and voltage (polarity). Also the multiplex has a null field for the inversion setting (but that defaults to auto in that case), so that shouldn't matter.

It looks to me like tuning is just plain failing here. Does it always fail on the same channels? Is it always channels on transports with a certain polarity or anything? Myth has had various retuning code enabled at various times (currently it doesn't have that), so maybe that was helping if for some reason tuning is flakey for this setup?

Just some ideas. I think we can rule out diseqc as the source of the problem though.

-yeasah

comment:4 Changed 13 years ago by danielk

(In [10961]) Refs #2226. Adds 'cmd_repeat' column to 'diseqc_tree' table.

This is for Yeasah's patch attached to #2226. It does not appear to fix the reported problem so I'm not going to risk applying it now, but allows for more robust DiSEqC so I plan to apply this to 0.20-fixes post release once it's been well tested and doing a DB upgrade to the fixes branch post release is a PITA..

comment:5 Changed 13 years ago by anonymous

Milestone: 0.200.21
Summary: Current SVN DVB-S zapping problems (diseqc?)DVB-S zapping problems

Yeasah, any reason you didn't use a numeric spin-box for the retry count entry?

Lucas, a few things

  • Do these channels show up in the internal MythTV channel scan?
  • Do you need to increase the timeouts for them to show up?
  • Can find the revision where this stopped working for you? It will probably give us more of a clue as to what happened.

comment:6 Changed 13 years ago by lukas.kasprowicz@…

I tested the patch with cmd_repeat int(3) in database. This does not fix the Problem.

Daniel: The channels are found with the current channel scan without increasing the timeout. I get the EPG for the channels that do not work, too!

I tested a few channels. Going to post this to mythtv-dev.

Lukas

comment:7 in reply to:  5 Changed 13 years ago by yeasah@…

Replying to anonymous:

Yeasah, any reason you didn't use a numeric spin-box for the retry count entry?

Sorry, no, I was short on time and just c&p'd another field (that obviously didn't happen to be integer) -- clearly it would be better as a number entry field.

Changed 13 years ago by yeasah@…

take into account polarity and band when considering whether to send committed diseqc messages

comment:8 Changed 13 years ago by yeasah@…

Attached patch (mythtv-diseqc-multiswitch.patch) to address the underlying issue.

Lukas reports that this works for his multiswitch, and I can confirm that it doesn't cause any regressions with my normal switch. So this ought to be sufficient to close the ticket.

The other patch (mythtv-diseqc-repeat-option.patch) doesn't actually pertain to the specific issue that opened this ticket, but at least one user has reported that the new option it provides in the UI allows them to achieve reliable switching where the default isn't sufficient, so it's useful too.

comment:9 Changed 13 years ago by Stuart Auchterlonie

Owner: changed from danielk to Stuart Auchterlonie

comment:10 Changed 13 years ago by Lueddich@…

Great work, works for me, too!

Thanks!

comment:11 Changed 13 years ago by michael@…

Fixed my problem! Great work! Thanks!

I've also filled a bug report at gentoo.org to include these patch at the ebuild.

Michael

comment:12 Changed 13 years ago by Stuart Auchterlonie

(In [11317]) Refs #2226. Applies Yeasah's patch to improve the sending of committed diseq messages.

comment:13 Changed 13 years ago by Stuart Auchterlonie

(In [11318]) Refs #2226. Adds Yeasah's patch to improve handling of committed diseqc messages.

comment:14 Changed 13 years ago by Stuart Auchterlonie

Resolution: fixed
Status: newclosed

(In [11319]) Closes #2226. Applies a modified version of Yeasah's patch to allow the setting of the diseq repeat count.

comment:15 Changed 13 years ago by Janne Grunau

fixed in branches/release-0-20-fixes by changeset [13218]

Note: See TracTickets for help on using tickets.