Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2241 closed defect (fixed)

Hue is distorted (Intel Chipset)

Reported by: panzaeron Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

With the SVN 10866 I have a problem with TVPlayback, because the HUE is distored at video and osd. I'm using a t-online S100 (or Bose Zenega 101S) with an Intel i830M Chipset. The problem is like http://svn.mythtv.org/trac/ticket/2175.

Attachments (6)

mythfrontend.log (19.1 KB) - added by panzaeron 13 years ago.
mythfrontend -v playback logfile
2241-v1.patch (590 bytes) - added by danielk 13 years ago.
possible fix
i830M Hue=0%.jpg (85.1 KB) - added by panzaeron 13 years ago.
i830M with hue=0% (mythtv-0.20)
i830M Hue=50%.jpg (83.9 KB) - added by panzaeron 13 years ago.
i830M with hue=50% (mythtv-0.20)
i830M Hue=99%.jpg (82.8 KB) - added by panzaeron 13 years ago.
i830M with hue=99% (mythtv-0.20)
i830mIEGD.patch (915 bytes) - added by greg 13 years ago.

Download all attachments as: .zip

Change History (16)

Changed 13 years ago by panzaeron

Attachment: mythfrontend.log added

mythfrontend -v playback logfile

comment:1 Changed 13 years ago by danielk

Milestone: 0.21
Owner: changed from Isaac Richards to danielk
Version: head

Changed 13 years ago by danielk

Attachment: 2241-v1.patch added

possible fix

comment:2 Changed 13 years ago by danielk

panzaeron, can you tell me if the attached patch fixes things for you?

If not can you tell me what hue if any makes the video look correct for you (without the patch) ?

To adjust the hue you will need to enable "Use Xv picture controls" on the second pane of "Utilities/Setup:Setup:TV Settings:Playback" in mythfrontend. Then press "F" while watching a recording until it says "Hue", and use the left and right arrows to adjust the hue.

comment:3 Changed 13 years ago by anonymous

The problem is not fixed with the patch, but I used the (SVN-Version 10845, with the actually Version I have a problem to make blend.o???). If I change the hue with your instructions, then I can change it, but not to the correct value.

comment:4 Changed 13 years ago by panzaeron

Summary: Hue ist distortet (Intel Chipset)Hue is distorted (Intel Chipset)

With the update SVN-Version (2006-09-04) I have the same problem. With hue = 50 %, the plants are green, but the people looks like light blue aliens and I can't change hue to a correct value.

Changed 13 years ago by panzaeron

Attachment: i830M Hue=0%.jpg added

i830M with hue=0% (mythtv-0.20)

Changed 13 years ago by panzaeron

Attachment: i830M Hue=50%.jpg added

i830M with hue=50% (mythtv-0.20)

Changed 13 years ago by panzaeron

Attachment: i830M Hue=99%.jpg added

i830M with hue=99% (mythtv-0.20)

comment:5 Changed 13 years ago by panzaeron

I've added some screenshots (MythTV-0.20). I hope this helps...

comment:6 Changed 13 years ago by panzaeron

The mpeg2 decoder (changed between Standard XvMC, Standard and libmpeg2) has no bearing on the hue problem.

comment:7 Changed 13 years ago by greg

This attached patch works for me using the i830M and IEGD driver on MSNTV2 units.

I imagine this should be made ./configure'able along with the ATI define.

Changed 13 years ago by greg

Attachment: i830mIEGD.patch added

comment:8 in reply to:  7 Changed 13 years ago by anonymous

Replying to greg:

This attached patch works for me using the i830M and IEGD driver on MSNTV2 units.

I imagine this should be made ./configure'able along with the ATI define.

The patch works fine for me :-) Thanks

comment:9 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

(In [11372]) Fixes #2241. Renames the hack for ATI's broken I420 support to be more generic and adds the Intel IEGD driver to the description.

The problem here appears to be a bug in the drivers, wrt the drivers' I420 support.

The YV12 support in these drivers isn't broken, so when this hack is enabled we just make YV12 preferred over I420.

The driver developers probably only tested with mplayer or Xine, which both default to YV12 over I420 when both are available.

comment:10 Changed 13 years ago by todd@…

I'm am being bitten by this bug. I'm using the Debian packages provided at debian-multimedia.org. Is it possible to get this patch included 0-20-fixes svn branch? This way the package maintainer can include it in the Debian packages.

Thanks

Note: See TracTickets for help on using tickets.