Opened 13 years ago

Closed 13 years ago

#2246 closed defect (invalid)

DVB-S with CAM broken in latest svn

Reported by: dave@… Owned by: danielk
Priority: trivial Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I had previously opened ticket #2110. This was put down to an incompatible CAM with the changes that Austar had made. I now have a new CAM that is confirmed as working with Austar. I no longer get the 'INSERT VALID CARD' error that I previously got so am reporting again.

My server is a Xeon EM64T running Gentoo kernel 2.6.17-r5 and MythTV trunk revision 10905. The sattelite provider is Austar in Australia.

Detail (edited) as posted to the -dev list:
I have a problem getting my DVB-S working with Austar here in Australia. I can view an FTA channel, but cannot view non-FTA channels on the same multiplex. I have attached a log with record,channel,siparser where I initially recorded from TVSN (A FTA channel) and then recorded from CNBC (A non-FTA channel). I get picture and sound from TVSN, but on CNBC I just get a black screen with a blue square in the bottom right hand corner.

The Austar subscription card works in my STB, the CAM has been checked and decrypts Austar fine and the card is working for FTA. I do get EIT data which I think must be encrypted as I don't get EIT data when the CAM isn't plugged in.

The specific card giving me grief is (lspci -v):
08:0d.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)

Subsystem: Technotrend Systemtechnik GmbH Technotrend-Budget /

Hauppauge WinTV-NOVA-CI DVB card

Flags: bus master, medium devsel, latency 64, IRQ 193
Memory at ddbffe00 (32-bit, non-prefetchable) [size=512]


And the replies:

On Fri, 2006-08-25 at 09:38 +0100, Stuart Auchterlonie wrote:

From what I can see the CA information streams aren't passed through
to the output PMT, and then tv_rec refuses to record the encrypted
stream.
either
a) the CA streams need to be passed through to the output PMT
b) the streams need decrypting before being send to the recorder.
Which one is the correct behaviour?


They need decrypting before being sent to the recorder.
What is supposed to happen is that when we get the input
PMT or CAT table and it tells us that something is
encrypted we send the CA info to the MythTV CAM module
which does the CAM magic. Meanwhile we strip any CA info
from the output PMT and ignore all encrypted streams.
Once the CAM kicks in it rewrites the flags on the
encrypted streams to tell the recorder it is safe to look
at those PIDs.

MythTV will refuse to record an encrypted stream if you
have "Free to air channels only" checked in the DVB Options
in mythtv-setups Input Connections pane for the input you
are using for this recording. It sounds like that might
be the case. Otherwise this might be a bug. None of the
regular devs use CAM so it might be a while before anyone
fixes a CAM bug, but they should still get tickets.

-- Daniel

Attachments (2)

mythbackend.log.gz (7.6 KB) - added by dave@… 13 years ago.
The log as specified in the description.
mythconverg.sql.gz (1.1 KB) - added by dave@… 13 years ago.
The database records as specified in the description.

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by dave@…

Attachment: mythbackend.log.gz added

The log as specified in the description.

Changed 13 years ago by dave@…

Attachment: mythconverg.sql.gz added

The database records as specified in the description.

comment:1 Changed 13 years ago by dave@…

Incidentally, I still have the issue defined in log 3 from issue #2110, but I'll wait until this main issue is fixed before following that one up.

comment:2 Changed 13 years ago by danielk

Milestone: unknown
Owner: changed from Isaac Richards to danielk
Priority: minortrivial

comment:3 Changed 13 years ago by dave@…

As posted to the dev list:
I have spent the day putting logging into mythtv and the Linux kernel to find out where this is going wrong. I think I have tracked it down to the dvb_ca_en50221.c code in the kernel and have posted the linux-dvb list. Can someone please close this issue as I don't want to waste anyones time by leaving the issue open. I may reopen it later if this turns out to be a red-herring.

comment:4 Changed 13 years ago by cpinkham

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.