Opened 13 years ago

Closed 13 years ago

#2248 closed defect (worksforme)

Unable to exit from recording screen when last recording is deleted.

Reported by: anonymous Owned by: Stuart Auchterlonie
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords: group filter recordings
Cc: Ticket locked: no

Description

If I select a group from the "Watch Recordings|Select Group Filter" menu, then delete all recordings from that group, I am unable to exit with the "ESC" key (No response from any keys).

View Recordings settings: Always prompt Save current group Show filter name

Change History (6)

comment:1 Changed 13 years ago by Isaac Richards

Milestone: 0.20

comment:2 Changed 13 years ago by Stuart Auchterlonie

It's a focus issue, if I hit 'm' to bring up the menu it won't pop up until I move the mouse onto the other screen, thereby moving the focus away from the frontend.

I suspect the X event generated by changing focus is enough to trigger the redraw/popup.

comment:3 Changed 13 years ago by cpinkham

Resolution: worksforme
Status: newclosed

Works fine here. Unless Stuart is going to look into this, someone needs to attach a gdb backtrace so we can figure out what's going on. Closing this ticket for now until someone reopens with the required backtrace. Docs for getting one using gdb and CTRL-C are in the HOWTO.

comment:4 Changed 13 years ago by Stuart Auchterlonie

Milestone: 0.21
Resolution: worksforme
Status: closedreopened

I'll look into this. It's a minor annoyance for me...

comment:5 Changed 13 years ago by Stuart Auchterlonie

Owner: changed from Isaac Richards to Stuart Auchterlonie
Status: reopenednew

comment:6 Changed 13 years ago by Stuart Auchterlonie

Resolution: worksforme
Status: newclosed

Can't reproduce this anymore

Note: See TracTickets for help on using tickets.