Opened 13 years ago

Closed 12 years ago

Last modified 11 years ago

#2263 closed patch (fixed)

Separate PCR pid (from Video) not recorded

Reported by: lpgcritter at nasquan dot com Owned by: Stuart Auchterlonie
Priority: major Milestone: 0.20
Component: dvb Version: 0.19
Severity: medium Keywords:
Cc: Ticket locked: no

Description

In Australia, most channels broadcast separate video/PCR pids. MythTV has logic for recording the PCR pid, but it fails because it never finds the TS Packet PayloadStart for the PCR pids, thus the PCR pids are not recorded on to the file.

My fix is to ignore the tspacket->PayloadStart?() condition for PCR pids.

Patch should be applied in libs/libmythtv

Attachments (5)

mythtv-0.19-pcr-patch (1.5 KB) - added by lpgcritter at nasquan dt com 13 years ago.
mythtv-trunk.patch (547 bytes) - added by lpgcritter at nasquan dt com 13 years ago.
fix for trunk
mythtv-0.19.patch (517 bytes) - added by lpgcritter at nasquan dt com 13 years ago.
new fix for 0.19
mythtv-0.21.patch (533 bytes) - added by lpgcritter 12 years ago.
Fixes the problem for 0.21 - PCR packets have no payload
mythtv-0.21.2.patch (575 bytes) - added by lpgcritter 12 years ago.
better patch

Download all attachments as: .zip

Change History (12)

Changed 13 years ago by lpgcritter at nasquan dt com

Attachment: mythtv-0.19-pcr-patch added

comment:1 Changed 13 years ago by danielk

Resolution: invalid
Status: newclosed

Please test against SVN head, a similar fix might be needed there as well.

Changed 13 years ago by lpgcritter at nasquan dt com

Attachment: mythtv-trunk.patch added

fix for trunk

Changed 13 years ago by lpgcritter at nasquan dt com

Attachment: mythtv-0.19.patch added

new fix for 0.19

comment:2 Changed 13 years ago by lpgcritter at nasquan dt com

Resolution: invalid
Status: closedreopened

I've added a fix for trunk and a better fix for 0.19. It would be great if both could be applied in svn.

The root cause of the problem is that the PCR packets did not have payload and only the adaptation field. Because the code searches for payloadstart to begin writing and payloadstart field is never 1 for packets without payload, the pcr ts packets never get recorded. The patch adds a bypass for packets which don't have payload.

comment:3 Changed 13 years ago by Stuart Auchterlonie

Milestone: 0.19.10.20
Owner: changed from danielk to Stuart Auchterlonie
Status: reopenednew

Due to the fact that 0.20 is in feature freeze I won't apply the 0.19 fixes, but will look at the patch for trunk for inclusion in 0.20

comment:4 Changed 13 years ago by Stuart Auchterlonie

Resolution: fixed
Status: newclosed

(In [11022]) Closes #2263. PCR packets don't have a payload so don't require a payload start in this situation.

comment:5 Changed 12 years ago by lpgcritter

Resolution: fixed
Status: closednew

Looks like problem has returned with the new multirec stuff

Changed 12 years ago by lpgcritter

Attachment: mythtv-0.21.patch added

Fixes the problem for 0.21 - PCR packets have no payload

Changed 12 years ago by lpgcritter

Attachment: mythtv-0.21.2.patch added

better patch

comment:6 Changed 12 years ago by danielk

Resolution: fixed
Status: newclosed

(In [16876]) Fixes #2263. Write IsWritingPID's even if they don't have a payload; PCR streams do not...

comment:7 Changed 11 years ago by simon@…

Can this patch be backported to 0.21-fixes? The bug it fixes renders a significant proportion of MythTV's DVB recordings unplayable in VLC.

Note: See TracTickets for help on using tickets.