Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2271 closed defect (duplicate)

DVB-C EIT stops mythbackend?

Reported by: petri@… Owned by: Stuart Auchterlonie
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have 3 DVB-C adapters in my setup and mythbackend will crash after some hours. Seems to be that there is problem with EIT? Possible similarities to Ticket #2268? I am using latest SVN.

Attachments (2)

gdb.txt (182.9 KB) - added by petri@… 13 years ago.
myth.log (109.0 KB) - added by petri@… 13 years ago.

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by petri@…

Attachment: gdb.txt added

Changed 13 years ago by petri@…

Attachment: myth.log added

comment:1 Changed 13 years ago by Stuart Auchterlonie

Owner: changed from Isaac Richards to Stuart Auchterlonie

Looks like it receives a broken packet as part of the PAT and incorrectly processes it. from the logfile

2006-08-29 19:47:06.347 AddTSPacket: Out of sync!!! Need to wait for next payloadStart
2006-08-29 19:47:06.351 SM(0)::AddFlags: Seen(PAT,) Match() Wait()
2006-08-29 19:47:06.351 SM(0)::AddFlags: Seen() Match(PAT,) Wait()
2006-08-29 19:47:06.352 CreatePATSingleProgram()
2006-08-29 19:47:06.353 PAT in input stream

The crash occurs when we attempt to convert the PAT using toString(). Obviously it's working on incorrect data.

comment:2 Changed 13 years ago by Stuart Auchterlonie

See also logs on #2274

comment:3 Changed 13 years ago by Stuart Auchterlonie

Resolution: duplicate
Status: newclosed

Duplicate of #2147, #2273, #2274

comment:4 Changed 13 years ago by Janne <janne-mythtv@…>

please test the fix in #2147

Note: See TracTickets for help on using tickets.