Opened 13 years ago

Closed 13 years ago

#2272 closed defect (fixed)

incorrect title in mythweb display

Reported by: jacksnodgrass <jack+mythtv@…> Owned by: xris
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The wrong title shows up for shows that appear in the timeslot of a previuosly recorded show. For example, the tv show '24' was in the Monday 8pm timeslot on FOX. The show is scheduled to be recorded in that timeslot each week.

'24' is over and has been replaced by 'Vanished'. The mythweb interface now shows the description and other details for Vanished but shows 24 as the title on the web page.

I have a patch to fix this. It's been attached. It is more of a hack than a patch.

It's hard to explain the real issue... it only shows up when a previous show in the timeslot was set up to be recoded and now a new show is listed in it's timeslot.....

jack

Attachments (3)

fix_title.diff (841 bytes) - added by jacksnodgrass <jack+mythtv@…> 13 years ago.
svn diff to mythweb/includes/programs.php
mythweb-notlisted.diff (1002 bytes) - added by bjm 13 years ago.
Check titles before replacing listings info with schedule info.
mythweb-notlisted2.diff (1.0 KB) - added by bjm 13 years ago.
Fix some errors in the earlier example patch.

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by jacksnodgrass <jack+mythtv@…>

Attachment: fix_title.diff added

svn diff to mythweb/includes/programs.php

comment:1 Changed 13 years ago by bjm

The problem is that rsNotListed entries in the real listings. This is because it is checking the channum and starttime and if they match and keeping the info from the scheduler rather than the info from the listings.

Around line 190 of includes/programs.php should check the title also to be sure it is the same program. See mythweb-notlisted.diff for an example, however, this may not be the ideal approach to coding this.

Changed 13 years ago by bjm

Attachment: mythweb-notlisted.diff added

Check titles before replacing listings info with schedule info.

Changed 13 years ago by bjm

Attachment: mythweb-notlisted2.diff added

Fix some errors in the earlier example patch.

comment:2 Changed 13 years ago by xris

Resolution: fixed
Status: newclosed

(In [10999]) Apply my own version of the title-check patch to close #2272 (handle display issues from schedule changes for certain recording types)

Note: See TracTickets for help on using tickets.