Opened 13 years ago

Closed 13 years ago

#2285 closed defect (invalid)

Recording deletion can cause temporary UI unresponsivenes with remote backends

Reported by: danielk Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This happens when the backend is remote and the recording which needs a deleting is not NFS mounted. The work around is to NFS mount the recording directory and configure the frontend to use the NFS mount via mythtv-setup on the frontend machine.

I haven't tracked down the cause, it appears to not be related to #2282, and it appears to not be related to preview generation (or at least not directly, it may be some side-effect that is only triggered some of the time.)

Attachments (1)

2285-dbg.patch (5.5 KB) - added by danielk 13 years ago.
Debugging patch

Download all attachments as: .zip

Change History (2)

Changed 13 years ago by danielk

Attachment: 2285-dbg.patch added

Debugging patch

comment:1 Changed 13 years ago by danielk

Resolution: invalid
Status: newclosed

It turns out that this was a local problem (unlike #2283 which has been fixed).

My remote frontend had what appears to have been a filesystem corruption causing stat() to take a very long time to check one particular zero length file. fsck is also refusing to run on that filesystem, which can't be a good thing.

Just in case this is not just an isolated incident, and we're actually doing something that is triggering the OS to block stat access, I've attached my debugging changes to the ticket. The change in mainserver.cpp are the relevant most one.

Without my local problem FillList?() still isn't super-fast, but it completes in 400 ms (with 200GB of recordings) not 10 seconds. FillList?() could probably be optimized to run in 100ms, but the effort isn't justified at the moment.

Note: See TracTickets for help on using tickets.