Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2294 closed defect (fixed)

Internal DVD player - chopping and pixelated picture

Reported by: anonymous Owned by: skamithi
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When playing "Madagascar" with the internal DVD player (SVN 10997), the main title is chopping and in sections where there's a lot of movement, the image gets pixelated or blocky. Interestingly, when I do 'mythfronend -v playback,audio' it goes away.

Attachments (2)

mythdvd_output (108.4 KB) - added by bhuffman@… 13 years ago.
Output with -v playback,libav
ticket_2294.diff (695 bytes) - added by skamithi 13 years ago.
reproduced the issue. if i disable seekreset at the start of a title, this seems to resolve the issue for me. pls test.

Download all attachments as: .zip

Change History (17)

Changed 13 years ago by bhuffman@…

Attachment: mythdvd_output added

Output with -v playback,libav

comment:1 Changed 13 years ago by Isaac Richards

Component: mythdvdmythtv
Owner: changed from Anduin Withers to skamithi
Priority: majorminor
Severity: highmedium

comment:2 Changed 13 years ago by bhuffman@…

Forgot to mention - it works flawlessly in xine with 'xine -pfhq dvd://'

comment:3 Changed 13 years ago by skamithi

can u reproduce this everytime with this dvd ? is this the only dvd you have found , so far, with this problem ? have u used libmpeg2 instead of the standard decoder and seen the same results ?

if the answer of all these questions is yes, then i'll add the movie to my netflix queue and attempt to reproduce this. i need to know the exact times during the movie where the blockiness occurs. give about 3 examples.

comment:4 Changed 13 years ago by bhuffman@…

1) YES - I can reproduce this every time 2) I haven't checked other DVDs with this SVN revision. I will do so as soon as I get a chance. I have to leave for the weekend but should be able to do this on Monday evening. 3) NO! Turns out if I use the libmpeg2, I get about 2-3 seconds of choppiness and pixelation during the Dreamworks opening, but then it's fine for the rest of the movie.

It seems to me like it has something to do with the A/V sync. That could be why there's no problem when I put the '-v playback,audio' debug flags in? The debugging slows something down enough that they're able to sync correctly? I dunno - just a guess.

comment:5 Changed 13 years ago by bhuffman@…

I have tested other DVDs. I can not find another DVD that responds the same way. FYI - this choppiness / pixelation seems to occur every time the DVD is accessed (approximately twice every second). Is there anything else that I can provide?

comment:6 Changed 13 years ago by skamithi

i put it my netflix list. i hope i can reproduce it. u are using the standard decoder setting right ? not xvmc ?

comment:7 Changed 13 years ago by bhuffman@…

Correct - standard decoder. I hope you're able to reproduce it as well. It worries me that it goes away when I run the frontend with '-v playback,audio' *even* using the standard decoder...

comment:8 Changed 13 years ago by skamithi

Milestone: unknown0.21
Status: newassigned
Version: head

Changed 13 years ago by skamithi

Attachment: ticket_2294.diff added

reproduced the issue. if i disable seekreset at the start of a title, this seems to resolve the issue for me. pls test.

comment:9 Changed 13 years ago by bhuffman@…

I'm beginning to think that there's more to this than this specific DVD. I've been having problems with general A/V sync when playing Videos as well. And looking at the user list, there have been a LOT of emails about problems with A/V sync or Audio cutting out. Something's going on with the Standard decoder that's affecting a lot of people (unfortunately not you or Isaac).

comment:10 Changed 13 years ago by gremlin190@…

Don't know if it relates, however whenever I check use audio as a timebase now in the tv playback setting I get a similar problem. I lose digital audio as it jumps back and forth from digital to analog and playback gets extremely choppy. I uncheck this box and everything is smooth again. I'm using FC5 and a few days before the .20 release. This is only with the internal dvd player. Live tv is fine (pvr250) Chad

comment:11 in reply to:  10 Changed 13 years ago by anonymous

Replying to gremlin190@yahoo.com:

Don't know if it relates, however whenever I check use audio as a timebase now in the tv playback setting I get a similar problem. I lose digital audio as it jumps back and forth from digital to analog and playback gets extremely choppy. I uncheck this box and everything is smooth again. I'm using FC5 and a few days before the .20 release. This is only with the internal dvd player. Live tv is fine (pvr250) Chad

Ooops, I meant to say video as a timebase.

comment:12 Changed 13 years ago by bhuffman@…

The patch fixes the issue for me in the main title! One question though - I'm still getting choppiness / intermittent audio loss in the initial dreamworks intro (before the root menu). Do you see this? If not, I suspect it's more of my A/V sync issues.... :-(

comment:13 Changed 13 years ago by skamithi

no chopiness in the initial intro for me. i would suggest trying gremlin1's suggestion of using video as the timebase. perhaps that will work better for you .

i'll commit the patch in this ticket this wknd. thanks for testing.

comment:14 Changed 13 years ago by skamithi

Resolution: fixed
Status: assignedclosed

(In [11275]) Closes #2294. internal dvd player: resolves choppy picture when starting the dvd main title.

comment:15 Changed 13 years ago by skamithi

(In [11326]) copy internal dvd player fixes from trunk to 0.20 fixes. Refs #2447, #2455, #2294

Note: See TracTickets for help on using tickets.