Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2304 closed defect (fixed)

Skipping forward can take you back to the start of a prgram

Reported by: willu.mailingLists@… Owned by: Nigel
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When skipping forward, the displayed time breifly flashes to 0:00 before skipping forward to the time requested. e.g. If I'm 1 min 40 secs into a program, and I skip forward 30 secs, then the display flashes 0:00 briefly before skipping forward to 2:20.

That flash is not a big problem, but if you skip forward two times in quick succession (by, say, using the auto-key-repeat), then sometimes the second skip seems to catch myth while it is back at 0:00, and you'll end up watching from 0:30 rather than whereever you wanted to be.

I've noticed this with r10995 and r10680. I suspect that this might be a MacOS bug, but I'm not sure. My normal Myth server's screen died recently, and so I'm using my Mac Laptop as a frontend for the moment. On my normal Myth box I was able to hold the lirc remote's skip button down and not have a problem. This has only become a problem while using the Mac frontend. If it matters, the shows being played back were recorded using DVB.

Because my main box has a broken screen, I can't go back and check if this is a problem under linux (using key-repeat instead of the LIRC remote), so I don't know who to assign the bug to. Sorry.

Change History (11)

comment:1 Changed 13 years ago by Isaac Richards

Owner: changed from Isaac Richards to Nigel

Doesn't repro on Linux, assigning to Nigel to check on a Mac.

comment:2 Changed 13 years ago by zylantha

comment:3 Changed 13 years ago by mythtv@…

Shoot, it's been doing it since I've had the frontend running on a Mac, starting in early 2005. I just wait for the real position to update before I hit skip again. Would be nice if it worked correctly, though.

This is with the backend file store mounted via NFS. Never tried it any other way.

comment:4 Changed 13 years ago by willu.mailingLists@…

Just a quick note: I'm using the default streaming interface, not NFS. I suspect that the backend supply of the data is irrelevant - it's a UI bug.

comment:5 Changed 13 years ago by Nigel

I can't make this happen regularly, but it seems co-incide with calls to UpdatePauseFrame?(). Probably related to this problem: http://www.gossamer-threads.com/lists/mythtv/dev/225719

comment:6 Changed 13 years ago by Nigel

comment:7 Changed 13 years ago by willu.mailingLists@…

I just tested the 'apparently working' patch on ticket #1151 with r11597. It solves the problem for me.

comment:8 Changed 13 years ago by ignasiak@…

I had not been seeing this problem in the 0.20 build I have been using, but I built the latest SVN version (as of 1/22/07) and this problem is back quite severely. Even moderately fast multiple keypresses causes it to reset to the start of the program.

comment:9 Changed 13 years ago by Nigel

Resolution: fixed
Status: newclosed

(In [13052]) Correct inappropriate usage of scratch frame. Closes #2304. See #1151. Sorry this took me so long - it was hard to reproduce. Will be applying on the 19 and 20 fixes branches too.

comment:10 Changed 13 years ago by Nigel

(In [13053]) Correct inappropriate usage of scratch frame. Closes #2304. See #1151.

comment:11 Changed 13 years ago by Nigel

(In [13054]) Correct inappropriate usage of scratch frame. See #2304. See #1151.

Note: See TracTickets for help on using tickets.