Opened 13 years ago

Closed 13 years ago

#2337 closed defect (worksforme)

Using Encoder Profile EP and LP, a half hour show is chopped to around 5 mins

Reported by: rbonafied@… Owned by: paulh
Priority: minor Milestone: unknown
Component: mytharchive Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

During my tinkering of various encoding profiles and trying to squeeze as much on a DVD as possible, I noticed the resulting DVD truncated each show to about 5 mins. This was using the 'Compact' theme.

Number of original shows: 23 half hour shows Originally encoded with: DVD Special 2 Approximate size of original half hour file: 750meg

It looks like the shows were truncated before the tcrequant stage. Leaving the encoding profile of 'Dont reencode' left the shows intact.

Attachments (1)

progress.log (8.1 KB) - added by anonymous 13 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by Isaac Richards

Milestone: 0.20unknown

comment:2 Changed 13 years ago by paulh

Resolution: invalid
Status: newclosed

Are you really trying to put 11 1/2 hours of video on a single DVD?

Can you reproduce this with a single file?

There isn't enought information here to even begin to guess why its failing and I'm not even going to try to reproduce this one. You are going to have to do some work to find out at what stage they are being truncated. You can reopen the ticket when you have more information to work on.

comment:3 in reply to:  2 Changed 13 years ago by anonymous

Replying to paulh:

Are you really trying to put 11 1/2 hours of video on a single DVD?

Can you reproduce this with a single file?

There isn't enought information here to even begin to guess why its failing and I'm not even going to try to reproduce this one. You are going to have to do some work to find out at what stage they are being truncated. You can reopen the ticket when you have more information to work on.

That's fair. I've since deleted the shows...but I'll try to reproduce it.

Changed 13 years ago by anonymous

Attachment: progress.log added

comment:4 Changed 13 years ago by rbonafied@…

Resolution: invalid
Status: closedreopened

Ok,

I'm able to reproduce this with just 3 half hour shows. Actually, I don't think it really matters how many shows since this appears to happen long before the DVD structure is created. I the show is getting truncated at the ffmpeg step. I am attaching the progress.log file and the mythburn.log.

Original file size(mpeg dvd-special2 encoded)

-rw-r--r-- 1 root root 825323520 Sep 7 20:00 /mythtv/capture/1004_20060907193000.mpg

Ls of work directory:

total 291244

drwxrwxrwx 2 mythtv mythtv 113 Sep 10 09:11 ./

drwxrwxrwx 6 mythtv mythtv 146 Sep 10 09:11 ../

prw-rw-rw- 1 mythtv mythtv 0 Sep 10 09:11 final.mpg|

-rw-rw-rw- 1 mythtv mythtv 506 Sep 10 08:38 info.xml

-rw-rw-rw- 1 mythtv mythtv 28743113 Sep 10 08:49 stream0.ac3

-rw-rw-rw- 1 mythtv mythtv 437 Sep 10 08:48 streaminfo.xml

-rw-rw-rw- 1 mythtv mythtv 269470815 Sep 10 08:49 stream.mv2

-rw-rw-rw- 1 mythtv mythtv 5848 Sep 10 08:49 thumbnail.jpg

Now a few particulars:

Distro: Mandriva LE2006

Myth SVN Revision: 11064

Package info:

libpython2.4-2.4.1-3mdk.i586.rpm

python-2.4.1-3mdk.i586.rpm

python-base-2.4.1-3mdk.i586.rpm

python-imaging-1.1.4-9mdk.i586.rpm

dvdauthor-0.6.11-5mdk.i586.rpm

ffmpeg-0.4.9-0.pre1.6.1.20060plf.i586.rpm

libffmpeg0-0.4.9-0.pre1.6.1.20060plf.i586.rpm

transcode-1.0.2-0.1.20060plf.i586.rpm

comment:5 Changed 13 years ago by paulh

I guess the mythburn.log file was rejected by trac for being too big. Could you compress it and email it to me. mythtv (at) dsl.pipex.com

Was all three files truncated this time or just one? Where they all truncated to the same length?

comment:6 in reply to:  5 Changed 13 years ago by anonymous

Replying to paulh:

I guess the mythburn.log file was rejected by trac for being too big. Could you compress it and email it to me. mythtv (at) dsl.pipex.com

Was all three files truncated this time or just one? Where they all truncated to the same length?

All three were truncated ranging from 3min 50secs to around 4mins 44 secs. I'll email the mythburn shortly. It will come from a slightly different email address... -Rick

comment:7 Changed 13 years ago by paulh

Resolution: worksforme
Status: reopenedclosed

This seems to be a problem specific to the OP's machine.

Note: See TracTickets for help on using tickets.