Opened 13 years ago

Closed 13 years ago

#2340 closed defect (duplicate)

"Error was encountered while displaying video" while watching livetv

Reported by: pasha Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Livetv dies with message "Error was encountered while displaying video" my config

SVN 11068 DVB.

Attachments (2)

frontend.zip (51.4 KB) - added by Bradley Kite <bradley.kite@…> 13 years ago.
Front End Log
backend.zip (4.1 KB) - added by Bradley Kite <bradley.kite@…> 13 years ago.
Back End Log

Download all attachments as: .zip

Change History (6)

comment:1 Changed 13 years ago by Nigel

Could you please attach some log files? (output from the mythbackend and frontend programs)

comment:2 Changed 13 years ago by benjsc (mythtv wiki)

Whilst I've got no logs, I notice it seems to happen at 12am a lot of the time. Perhaps its a date related bug.

comment:3 Changed 13 years ago by Bradley Kite <bradley.kite@…>

Hi all,

I initially posted this ref #1153.

I have some logs attached and some further info on the problem that is occuring.

It would appear as if the back-end is renaming the ring-buffer 2 seconds after its initially switched it.

The Simpsons ran on Channel 4 from 18:00 to 18:30, at which time Hollyoaks started.

The problem occured at between 18:30:02 and 18:30:07 - the back-end initially decided that the recoding of Hollyoaks should be /mnt/store1004_20060831180000.mpg - which is correct in my view because thats when the program started.

However, 2 seconds later it decided that the recording should in fact be /mnt/store1004_20060831183002.mpg - I dont know why it does this.

The front-end "knows" that its getting near the end of the Simpsons, because it starts making calls to IsReallyNearEnd?(), but then at 18:30:02 it tries to open myth://127.0.0.1:6543/1004_20060831183000.mpg which would/should be the correct file name, but instead the back-end has renamed it to be 1004_20060831183002.

I've attached front-end and back-end logs with all this, and have added some comments.

Any help will be much appreciated.

btw, front-end and back-end are on the same machine, so this shouldnt be a clock issue.

If any further info is required, please let me know and I'll try and obtain it.

Regards -- Brad.

Changed 13 years ago by Bradley Kite <bradley.kite@…>

Attachment: frontend.zip added

Front End Log

Changed 13 years ago by Bradley Kite <bradley.kite@…>

Attachment: backend.zip added

Back End Log

comment:4 Changed 13 years ago by danielk

Resolution: duplicate
Status: newclosed

Duplicate of #1153.

Note: See TracTickets for help on using tickets.