Opened 13 years ago

Closed 12 years ago

#2341 closed defect (worksforme)

Frontend segfault in [Edit Recording Schedule]

Reported by: jppoet@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: high Keywords:
Cc: Ticket locked: no

Description (last modified by cpinkham)

I have a "custom" record rule setup which has:

program.title like "Sharp's%"

From the show menu, if I highlight one of the episodes recorded, and select:

[Recording Options]

[Edit Recording Schedule]

The frontend always segfaults. I have attached a BT.

If it helps (probably not) ....

In scheduledrecording.h:

virtual int exec(bool saveOnExec = true, bool doLoad = false)

{ return ConfigurationDialog::exec(saveOnExec, doLoad); }

saveOnExec = true doLoad = false

In playbackbox.cpp : void PlaybackBox::doEditScheduled()

curitme = (ProgramInfo? *) 0xa9bba508

Attachments (1)

bt-edit-recording-schedule (41.6 KB) - added by jppoet@… 13 years ago.
BT of frontend segfault

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by jppoet@…

Attachment: bt-edit-recording-schedule added

BT of frontend segfault

comment:1 Changed 13 years ago by jppoet@…

Sorry, just realized this is a dupe of 2184.

comment:2 Changed 13 years ago by paulh

Is this still reproducible with current svn? Seems to be working OK for me.

comment:3 Changed 12 years ago by cpinkham

Description: modified (diff)
Resolution: worksforme
Status: newclosed

Am unable to reproduce this with current SVN trunk and I just closed another duplicate of this ticket so I'm going to close this one as well unless someone can reproduce with current SVN trunk head and submit a backtrace.

Note: See TracTickets for help on using tickets.