Opened 13 years ago

Closed 13 years ago

#2347 closed defect (duplicate)

Fatal error: Call to a member function on a non-object in includes/programs.php on line 193

Reported by: Pekka Jääskeläinen <pekka.jaaskelainen@…> Owned by: xris
Priority: minor Milestone: unknown
Component: mythweb Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I added 'if ($program != NULL)' before the line 193 to fix it. The patch being:

Index: includes/programs.php
===================================================================
--- includes/programs.php       (revision 11075)
+++ includes/programs.php       (working copy)
@@ -190,7 +190,8 @@
             if ($Scheduled_Recordings[$data['channum']][$data['starttime_unix']][0]->title == $data['title']) {
                 $program =& $Scheduled_Recordings[$data['channum']][$data['starttime_unix']][0];
             // merge in data fetched from DB
-                $program->merge(new Program($data));
+                if ($program != NULL)
+                    $program->merge(new Program($data));
             }
         // Otherwise, create a new instance of the program
             else {

Change History (1)

comment:1 Changed 13 years ago by xris

Resolution: duplicate
Status: newclosed

Dupe of #2314

Note: See TracTickets for help on using tickets.