Opened 13 years ago

Closed 11 years ago

#2359 closed defect (worksforme)

internal player: the frame count is too low when playing .avi (gets synced to correct value after seeking)

Reported by: Pekka Jääskeläinen <pekka.jaaskelainen@…> Owned by: cpinkham
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

The internal player seems to get wrong frame counts for avis when starting to play it. After seeking the frame count gets synched to a correct value. This problem was revealed with a .avi and an external frame-based subtitles: the subtitles were out of synch (about 1-2 secs too late) when playing the file from the beginning, and got back to synch after seeking once to some direction.

I started to track this problem, but ran out of (non-occupied backend) time for now. I think the problem is that the framesPlayed is stored in multiple different classes (NVP, Decoder, VideoOut?) and they get out of sync with each other at the beginning and the seeking syncs the correct framesPlayed value to the VideoOut? which is used by the text subtitle display code at NVP. I also tried using the NVP framesPlayed instead of the current videoOut's currentFrame framesPlayed for syncing the subs, but it didn't help.

Anyways, if someone knows immediately what the problem can be, great. Otherwise, I'll look into this later when I have time again. It doesn't seem to affect anything but the syncing of frame-based external subs...

Change History (5)

comment:1 Changed 13 years ago by cpinkham

Owner: changed from Isaac Richards to cpinkham

comment:2 Changed 13 years ago by Pekka Jääskeläinen <pekka.jaaskelainen@…>

I've also noted that sometimes the playback starts 1-2 secs too late, thus not completely from the beginning. I have to seek back to get to the start position. I wonder if this symptom is related to this issue.

comment:3 Changed 12 years ago by danielk

Version: head

comment:4 Changed 11 years ago by Dibblah

Status: newinfoneeded_new

Is this fixed with trunk? There was a change to seek to the beginning of file on the start of playback.

comment:5 Changed 11 years ago by Dibblah

Resolution: worksforme
Status: infoneeded_newclosed
Note: See TracTickets for help on using tickets.