Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2368 closed defect (fixed)

Scheduling program manually causes it to show up twice in media library list and mythweb recorded shows listing

Reported by: rbonafied@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I scheduled a recording using manual schedule and picked a duration of approximately 10 minutes. The show was listed twice in the Media Library screen and from the mythweb records shows screen.

Values entered:

Channel 4

Time: 11pm

Duration: 10 mins

No special recording options

Change History (6)

comment:1 Changed 14 years ago by anonymous

Milestone: unknown0.20

comment:2 Changed 14 years ago by Isaac Richards

Milestone: 0.20unknown

comment:3 Changed 14 years ago by istvan43@…

I can confirm this.

Manual recording were fine in 0.19. After I upgraded to 0.20, they started showing twice in the recording list. A show recorded after the upgrade to 0.20 also shows up twice.

comment:4 Changed 14 years ago by anonymous

The problem appears to be that there are two records being inserted into the recordedprogram table: one is the manual recording and the other is the data for the program information for the program that started at the time the manual recording started. Hope this sheds more light on the problem.

comment:5 Changed 14 years ago by cpinkham

Resolution: fixed
Status: newclosed

(In [11262]) In ProgramInfo::StartedRecording?, we need to check more than the chanid and starttime when copying the program info from the program table to the recordedprogram table. This is because a manually scheduled recording can mask a normal program listing, but both are still in the program table.

This mod makes StartedRecording? check the program title in addition to the chanid and starttime when copying data to make sure we are copying the right data. Previously we'd copy the wrong data which caused duplicate rows to appear on the Watch Recordings screen for the manually scheduled recording.

Closes #2368.

comment:6 Changed 14 years ago by cpinkham

(In [11263]) Carry over [11262] from head. References #2368.

Commit log for [11262]:

In ProgramInfo::StartedRecording?, we need to check more than the chanid and starttime when copying the program info from the program table to the recordedprogram table. This is because a manually scheduled recording can mask a normal program listing, but both are still in the program table.

This mod makes StartedRecording? check the program title in addition to the chanid and starttime when copying data to make sure we are copying the right data. Previously we'd copy the wrong data which caused duplicate rows to appear on the Watch Recordings screen for the manually scheduled recording.

Note: See TracTickets for help on using tickets.