Opened 14 years ago

Closed 14 years ago

#2383 closed patch (fixed)

Remove direct calls to glXWaitVideoSyncSGI and glXGetVideoSyncSGI (use glXGetProcAddressARB to find them)

Reported by: Anduin Withers Owned by: Anduin Withers
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

It looks like the Linux GL ABI makes no guarantees about the extensions being directly linkable. Apparently newer Mesa has removed these symbols from libGL.

Attachments (2)

vsync.patch (4.5 KB) - added by Anduin Withers 14 years ago.
mythtv-0.20-vsync.patch (4.6 KB) - added by cardoe@… 14 years ago.
The patch here did not compile for me. Here's a refactored version that doesn't use templates

Download all attachments as: .zip

Change History (8)

Changed 14 years ago by Anduin Withers

Attachment: vsync.patch added

Changed 14 years ago by cardoe@…

Attachment: mythtv-0.20-vsync.patch added

The patch here did not compile for me. Here's a refactored version that doesn't use templates

comment:1 Changed 14 years ago by tino.keitel+mythtv@…

I can confirm that this patch builds with newer Mesa (6.5.1) and SVN 11316.

comment:2 Changed 14 years ago by Anduin Withers

Resolution: fixed
Status: newclosed

(In [11395]) Closes #2383

New Mesa 3D stuff doesn't allow direct linking to glXGetVideoSyncSGI glXWaitVideoSyncSGI, etc (conforms to the linux ABI for GL).

If this doesn't compile for you, reopen this ticket and send your build output to the list.

Thanks to Cardoe for an updated patch.

comment:3 Changed 14 years ago by Stuart Auchterlonie

Resolution: fixed
Status: closedreopened

Fails to compile for me

vsync.cpp: In member function 'void (* OpenGLVideoSyncPrivate::glXGetProcAddress(const char*))()':
vsync.cpp:470: error: 'glXGetProcAddressARB' was not declared in this scope

Looks like the #define GLX_GLXEXT_PROTOTYPES that was in both versions of the patch got lost. I'll submit the fix shortly.

comment:4 Changed 14 years ago by Stuart Auchterlonie

Resolution: fixed
Status: reopenedclosed

(In [11397]) Closes #2383. re adds #define GLX_GLXEXT_PROTOTYPES which was missed out and is needed to allow compilation.

comment:5 Changed 14 years ago by anonymous

Resolution: fixed
Status: closedreopened

I hope re-opening this ticket is the correct way to identify that these changesets also need applying to 20-fixes branch as well as this no longer compiles with new Mesa installed

comment:6 Changed 14 years ago by Anduin Withers

Resolution: fixed
Status: reopenedclosed

(In [11610]) Closes #2383 for -fixes by applying [11395] and [11397] from trunk.

Fixes glX..() direct linking for new Mesa

Note: See TracTickets for help on using tickets.