Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#2391 closed defect (fixed)

CC, stereo, HD icons don't always appear

Reported by: ylee@… Owned by: stuartm
Priority: major Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords: icons hd cc stereo
Cc: Ticket locked: no

Description

In 0.20.20060828-3 (ATrpms on Fedora Core 4, MythCenter? theme), the CC, stereo, and HD icons don't always appear on the recordings list. Taking as examples five programs recorded consecutively Wednesday night and Thursday early morning, with the relevant keywords from Program Details:

HDNet - Arrested Development (HDTV, CC, Stereo) - No icons HDNet - Arrested Development (HDTV, CC, Stereo) - All three icons FOX - Bones (TV-14, HDTV, CC, Stereo) - No icons CBS - Late Show with David Letterman (TV-PG, HDTV, CC, Stereo) - No icons NBC - Late Night With Conan O'Brien (TV-14, HDTV, CC, Stereo) - All three icons

Scrolling through my library, I see icons appearing on perhaps 25% of my recordings. In one case (an episode of "Justice") the icons appear without any of the keywords in Program Details, which tells me the keywords aren't actually the flags mythfrontend reads to display the icons.

Attachments (1)

recorded_table_linking_fix.diff (1.9 KB) - added by stuartm 12 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 13 years ago by stuartm

Can you post the result of {{ SELECT stereo, closecaptioned, hdtv FROM recordedprogram }} for one/two of the affected programmes?

If you have a lot of recordings, you'll probably want to add a WHERE clause to that statement - either by chanid and starttime or title.

comment:2 Changed 13 years ago by stuartm

Owner: changed from Isaac Richards to stuartm

comment:3 Changed 13 years ago by stuartm

Resolution: worksforme
Status: newclosed

comment:4 in reply to:  1 Changed 12 years ago by ylee@…

Resolution: worksforme
Status: closedreopened

Replying to stuartm:

Can you post the result of {{ SELECT stereo, closecaptioned, hdtv FROM recordedprogram }} for one/two of the affected programmes?

Sorry to take so long to get back to your request. I don't know SQL syntax and it took me a while to figure out how to do what you asked for.

Here's what I get with

SELECT stereo, closecaptioned, hdtv FROM recordedprogram WHERE starttime = "2007-02-18 08:30:00";

+--------+----------------+------+
| stereo | closecaptioned | hdtv |
+--------+----------------+------+
|      1 |              1 |    1 | 
+--------+----------------+------+

This program is one that, on the Program Details page, says "(HDTV, CC, Stereo)," but does not have any of these icons appear on the Watch Recordings page.

Here's what I get with

SELECT stereo, closecaptioned, hdtv FROM recordedprogram WHERE starttime = "2007-02-15 21:00:00";

+--------+----------------+------+
| stereo | closecaptioned | hdtv |
+--------+----------------+------+
|      1 |              1 |    1 | 
+--------+----------------+------+

This program is one that, on the Program Details page, says "(TV-PG, HDTV, CC, Stereo)," and does have all three icons appear on the Watch Recordings page. As you can see, no difference.

I can't figure out any rhyme or reason as to what causes the icons to appear or not. It's not whether the program is marked with a TV-rating tag, for example; in the previous example, right above that recording in my Watch Programs list is another that is marked as "(TV-14, HDTV, CC, Stereo)" but has no icons.

One more data point: As far as I can tell, it's always an either/or situation: That is, with multiple tags, there will never be a situation in which one icon appears but another doesn't.

comment:5 Changed 12 years ago by stuartm

Milestone: 0.21
Version: 0.20head

Checking my recordings I've found the same behaviour, so that should make it easier to debug.

comment:6 Changed 12 years ago by stuartm

Priority: minormajor
Severity: lowmedium

I've found the cause and it turns out to be a little more serious issue than I originally thought. A patch to fix new recordings is attached. A fix for old recordings will be included soon.

comment:7 Changed 12 years ago by stuartm

Removed the patch, it won't fix the problem.

Changed 12 years ago by stuartm

comment:8 Changed 12 years ago by stuartm

Attached a working fix this time, although it's untested. It's aesthetically ugly, but has the advantage of being unintrusive and very simple.

This should also fix both old and future recordings.

comment:9 Changed 12 years ago by stuartm

Resolution: fixed
Status: reopenedclosed

(In [13339]) Fixes #2391

We weren't linking against the recordedprogram table in cases when the programme start time and recording start time don't match.

This problem dates back to when we started storing the recording start time in the starttime column, as opposed to the programme start time. This was bound to cause some confusion, because starttime in one table may not equal starttime in another.

comment:10 Changed 12 years ago by stuartm

(In [13340]) Backports [13339] to -fixes

Fixes hdtv, stereo and subtitle icons, by ensuring we link correctly against the recordedprogram table.

comment:11 in reply to:  10 Changed 12 years ago by ylee@…

Replying to stuartm:

(In [13340]) Backports [13339] to -fixes

I can verify that r13340 indeed appears to fix the problem for both old and new recordings. Thanks, Stuart, for both the fix and for the backport.

Note: See TracTickets for help on using tickets.