Opened 13 years ago

Closed 12 years ago

#2394 closed defect (fixed)

Live TV refuses to change channel if the other card is on the same channel.

Reported by: Stuart Auchterlonie Owned by: Janne Grunau
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: low Keywords:
Cc: stuartm Ticket locked: no

Description (last modified by stuartm)

Steps to reproduce.

1) on card #1 tune to a channel (say ch 70) 2) switch to card #2 3) attempt to change channel to ch 70.

The channel change doesn't occur. Looks like it thinks it's already on the channel.

Change History (4)

comment:1 Changed 12 years ago by stuartm

Cc: stuartm added
Description: modified (diff)

comment:2 Changed 12 years ago by Janne Grunau

we are aborting channel changing in TVPlay::ChangeChannel?() if the channum matches the back of the previous channel list. Switch[Input|Cards|Source] doesn't update the previous channel list. It's unfortunately not obvious how to fix it.

comment:3 Changed 12 years ago by Janne Grunau

Owner: changed from Stuart Auchterlonie to Janne Grunau
Status: newaccepted

just testing a fix

comment:4 Changed 12 years ago by Janne Grunau

Resolution: fixed
Status: acceptedclosed

(In [15919]) Fixes #2394 by updating the previous channel list after successfully switching the card

Note: See TracTickets for help on using tickets.