Opened 13 years ago

Closed 13 years ago

#2396 closed defect (invalid)

Via XVMC Acceleration does not play videos bigger than 704x496

Reported by: mac Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I am experiencing problems with the Via XVMC acceleration. I use a Via EPIA board with a unichrome chipset. I am required to use ViaXVMC to avoid stuttering in the video.

mythtv 0.20-fixes (the svn branch) is compiled with --enable-xvmc --enable-xvmc-vld.

Videos that have a higher resolution than 704x496 just display a black picture (no osd either) and just sound. Including old recordings from 0.19. If the resolution is lower, everything works fine.

I attached 2 logfiles, one with the working resolution (704x496), and one with 720x576.

This used to work fine in 0.19. Thank you for your help :)

Attachments (2)

myth_badresolution.txt (188.4 KB) - added by anonymous 13 years ago.
Recorded at 720x576, showing no video
myth_workingresolution.txt (99.4 KB) - added by anonymous 13 years ago.
Recorded at 704x496... works just fine

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by anonymous

Attachment: myth_badresolution.txt added

Recorded at 720x576, showing no video

Changed 13 years ago by anonymous

Attachment: myth_workingresolution.txt added

Recorded at 704x496... works just fine

comment:1 Changed 13 years ago by mac

I solved the issue. While I don't know if its a mythtv issue, it may be, because it all worked in 0.19.

The reason why it doesn't display a picture is in the xorg log file:

DRM memory allocation failed (EE) VIA(0): [Xv] Port 0: Not enough resources to complete the request. Probably out of memory.

Increasing the onboard memory didn't do anything, so its not really the memory. It's also not the system memory (150mb free). Somehow, maybe mythtv tells the via driver to allocate too much memory. It mayb be related to the (new) (unfinished) opengl code.

As soon as I disabled the "glx" module in xorg.conf, it started working. It might be a bug in mythtv.

comment:2 Changed 13 years ago by danielk

Resolution: invalid
Status: newclosed

Driver problem, fixed in latest OpenChrome? SVN. The VIA driver wasn´t allocating the memory when MythTV asked for the HDTV XvMC surface and was hence failing too late for MythTV to respond to the failure. The VIA driver as of two months ago has been confirmed to work with the code in the mythtv-vid branch.

Note: See TracTickets for help on using tickets.