Opened 14 years ago

Closed 14 years ago

#241 closed enhancement (duplicate)

PAL-I problem & unpleasant fix

Reported by: swesemeyer@… Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: mythtv Version: 0.18.1
Severity: medium Keywords: PAL-I TV norm audio static
Cc: Ticket locked: no

Description

I filed this in bugzilla already but bugzilla seems to have been removed so I just refile it here for reference in case someone else comes across the same problem.

MythTV does not allow the specification of PAL-I as the TV norm instead it only allows the user to select PAL which I believe translates to v4l2_STD_PAL (for the v4l2 API). At least for the Conexant based Hauppauge WinTV PCI FM card this means that the TV norm gets set to PAL-BG when MythTV tunes for the card for the first time. In PAL-I countries like the UK this results in recording a perfect picture with static noise audio.

The workaround for the time being is to recompile the cx88xx-video.c source as follows (this is copied from Andrew Wilkinson's post to the v4l mailing list): <quote> In cx88-video.c change (it's about line 1,389) from cx88_set_tvnorm(dev->core,&tvnorms[i]); to cx88_set_tvnorm(dev->core,&tvnorms[4]);

Then recompile, install and load the cx8800 and cx88xx modules.

This ignores the tv norm the application is using and forces it to use PAL_I. Seeing as I doubt I'll ever be using my computer somewhere that isn't PAL_I this is a reasonable thing to do.

</quote>

Ideally, it would be great if MythTV could offer an option to specify which PAL norm should be used for V4L2_STD_PAL either as a start-up parameter or a config option somewhere.

Change History (1)

comment:1 Changed 14 years ago by Isaac Richards

Resolution: duplicate
Status: newclosed

Dupe of #228.

Note: See TracTickets for help on using tickets.