Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 8 years ago

Closed 7 years ago

#2412 closed defect (fixed)

Higher CPU load and hickups in audio and picture on EPIA-M 1000 (XvMC)

Reported by: michel@… Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

With version 0.20 and SVN revision 11222 I get higher CPU load and hickups in audio and picture on an EPIA-M 10000. When I go back to version 0.19 al is fine.
This is both for recorderd programs and livetv. (most programs were recorded with 0.19)
CPU load on 0.19 = around 15 ~ 20%
CPU load on 0.20+ = around 45 ~ 70%

All versions are compiled the same way. (./configure --prefix=/usr --disable-xvmc-pro --enable-xvmc --arch=i586)

Attachments (5)

mythfrontend.log (6.5 KB) - added by michel@… 8 years ago.
log file of mythfrontend
frontoutpvr (30.4 KB) - added by DannyCan@… 8 years ago.
"mythfrontend -l frontout -v playback" command from knoppmyth box
frontoutpc (29.6 KB) - added by anonymous 8 years ago.
"mythfrontend -l frontout -v playback" command from ubuntu box
OSD_0-20_Patch.diff (2.7 KB) - added by bmhowe@… 7 years ago.
Stop OSD from getting drawn twice (patch to 0.20-fixes)
2412-v1.patch (3.0 KB) - added by danielk 7 years ago.
Backport of [11327] and [11364] to 0.20-fixes

Download all attachments as: .zip

Change History (22)

comment:1 Changed 8 years ago by michel@…

Extra info: The EPIA-M is only running mythfrontend.

#dmesg:
drm and via kernel module info.
[drm] Initialized drm 1.0.1 20051102
[drm] Initialized via 2.10.2 20060616 on minor 0:

#Xorg.log
X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.9-34.ELsmp i686Red Hat, Inc.

Changed 8 years ago by michel@…

log file of mythfrontend

comment:2 Changed 8 years ago by DannyCan@…

I've also been having this problem ever since I upgraded to .20.
I have 2 systems running .20, one has a geforce MX4000 with the nvidia 7184 driver running the latest knoppmyth distro and the other has a geforce 7600GT with the 8774 driver running the latest ubuntu distro.
When I have XvMC enabled on them and I try to watch HDTV, it doesn't seem to be accelerating. The knoppmyth box studders constantly and it's unwatchable and the ubuntu box has a high cpu load and pauses sometimes.
I'm attaching the log from the “mythfrontend -l frontout -v playback” command from both systems which might shed some light on this issue.

Changed 8 years ago by DannyCan@…

"mythfrontend -l frontout -v playback" command from knoppmyth box

Changed 8 years ago by anonymous

"mythfrontend -l frontout -v playback" command from ubuntu box

comment:3 Changed 8 years ago by michel@…

Lost the audio buffer underrun by disabling deinterlace option in playback settings.
Was deinterlace using Bob.
Picture is now sometime jerkey. CPU is still high around 40 ~50 %.

comment:4 Changed 8 years ago by danielk

  • Owner changed from ijr to danielk

Please find the specific revision in SVN HEAD where this problem begins.

There weren't any significant changes to XvMC between 0.19 and 0.20.

comment:5 Changed 8 years ago by danielk

  • Resolution set to invalid
  • Status changed from new to closed

comment:6 Changed 8 years ago by michel@…

Last weekend I upgraded the backend kernel from 2.6.17 to 2.6.18, frontend was allready 2.6.18. And updated to latest SVN and the frontend reacted normal again (CPU between 10 ~ 20 %).

When I use ATRPMS packages the frontend gives me a high load again.

My solution was make sure backend and frontend are same kernel version. Other problem might be that i'm using hauppauge pvr cards in the backend. The ivtv drivers were changed for kernel 2.4.18 and for this also myth 0.20.

comment:7 Changed 7 years ago by leif@…

XvMC stutters and uses greatly more processor in 0.20 for me as well, with my NVIDIA 6200 card. X consumes a lot of CPU when using XvMC/0.20, whereas with 0.19 it uses virtually none.

comment:8 follow-up: Changed 7 years ago by DannyCan@…

This problem seems to be fixed in the latest .21 svn code.
I suggest you give it a try.

comment:9 in reply to: ↑ 8 Changed 7 years ago by anonymous

Thanks DannyCan?!

I just patched 0.20-fixes (checked out this afternoon) with changeset 11327 from trunk. It almost applies cleanly. 'patch' complains about one hunk, because the change has already been made, so it can be ignored.

With it, my XvMC processor utilization drops back to 0.19 levels.

comment:10 Changed 7 years ago by michel@…

I can confirm that current svn solves high cpu on epia-m with XvMC. It is normal again. Thank you

comment:11 Changed 7 years ago by bmhowe@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

I think the patches from r11327 and r11364 should be rolled in to release-0-20-fixes. Without this patch, I could not watch my HD recordings with XvMC, and I almost rolled back to 0.19 (until I found this patch). Since the work has already been done, I just rolled the patches in to a diff from 0.20-fixes and have attached them here. Could somebody commit these to the 0.20-fixes branch?

Changed 7 years ago by bmhowe@…

Stop OSD from getting drawn twice (patch to 0.20-fixes)

comment:12 Changed 7 years ago by midl_man@…

I concur -- please commit to 0.20-fixes. I've applied the patches mentioned to my snapshot it makes a significant difference when playing 720p HD source material on a Via EPIA-SP13000. I've been using it for two days with no problems and playback is very smooth now as opposed to the marginal playback I had been experiencing.

Changed 7 years ago by danielk

Backport of [11327] and [11364] to 0.20-fixes

comment:13 Changed 7 years ago by danielk

I've backported the fix with some changes and verified that it doesn't break XvMC for me. Please test with XvMC-VLD and I will apply the patch.

comment:14 Changed 7 years ago by midl_man@…

Tested 2412-v1.patch applied to 12770 with both 720p and DVD content with XvMC-VLD on CN400 chipset and it looks fine. It appears to eliminate the last little bit of occasional AV dropouts that were occurring on the 720p content.

comment:15 Changed 7 years ago by anonymous

Can this be applied to 0.20-fixes now ?

comment:16 Changed 7 years ago by jarod

danielk is currently in the process of moving, but he has given this patch the thumbs up to be included and asked me to go ahead and do so. I'll get it committed shortly...

comment:17 Changed 7 years ago by jarod

  • Resolution set to fixed
  • Status changed from reopened to closed

Changeset [12825] carries this fix.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.