Opened 13 years ago

Closed 13 years ago

#2422 closed defect (worksforme)

mythtv-setup failure (not using XMLTV)

Reported by: mythtv@… Owned by: stuartm
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Library API : 0.20.20060915-1 Source Version : 11242M

In mythtv-setup (libmythtv videoource.cpp)

XMLTVConfig::XMLTVConfig... it seems that while(find_grabber_proc.isRunning()) will never time out when XMLTV is not configured or used. In my case I only use EIT for schedule data.

Base install was KnoppMyth? R5D1 setup and run. Downloaded svn, built, and installed.

Change History (2)

comment:1 Changed 13 years ago by stuartm

Milestone: unknown0.21
Owner: changed from Isaac Richards to stuartm
Version: 0.20head

comment:2 Changed 13 years ago by stuartm

Resolution: worksforme
Status: newclosed

I cannot reproduce, if I remove tv_find_grabbers OR remove all the grabbers then I just get the datadirect, eit only and no grabber options - no hang or other unusual behaviour.

If you still see this problem, then I'll need more details: Is tv_find_grabbers present on your system? What symptoms are you seeing? How did you come to the conclusion that while(find_grabber_proc.isRunning()) was never timing out?

Logs with "-v all" would be helpful as well as any output you might have from gdb.

Note: See TracTickets for help on using tickets.