Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#2429 closed defect (wontfix)

Autodetect video scan is confused by 1080i recordings

Reported by: jakep_82@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: low Keywords:
Cc: Ticket locked: no

Description

When playing back 1080i recordings using autodetect, de-interlacing is turned off and on repeatedly. The result is intermittent "combing". Changing video scan from Detect to Interlaced solves the problem but isn't very elegant. Playback is on a remote frontend. Both machines are running 0.20-fixes 11067. Frontend log attached.

Attachments (1)

frontend.log (28.3 KB) - added by jakep_82@… 14 years ago.

Download all attachments as: .zip

Change History (11)

Changed 14 years ago by jakep_82@…

Attachment: frontend.log added

comment:1 in reply to:  description Changed 14 years ago by list-mythtv@…

Confirmed to be seen with 1080i OTA ASTC sources in Raleigh/Durham? NC. Using myth 0.20 on gentoo.

comment:2 Changed 14 years ago by Isaac Richards

Resolution: wontfix
Status: newclosed

That's normal.

comment:3 Changed 14 years ago by stantonx@…

Resolution: wontfix
Status: closedreopened

I'm experiencing the same thing. http://www.gossamer-threads.com/lists/mythtv/users/225604 Didn't do this in 0.18.1 or 0.19 svn or 0.19, but now it is in 0.20. Quite noticable and annoying. I wouldn't consider it "normal".

comment:4 Changed 14 years ago by Isaac Richards

Resolution: invalid
Status: reopenedclosed

comment:5 Changed 14 years ago by jshatch@…

Priority: minormajor
Resolution: invalid
Severity: lowmedium
Status: closedreopened

This ticket *isn't* invalid and shouldn't be closed. I've read the thread that explains your thinking on this, but the bottom line is this: The problem exists, it's pretty annoying, and if Mythtv is getting the scan information from the video headers and they're broken, then Mythtv shouldn't be getting that information from there. Instead there should be an option to do things *exactly* like it was done in .19, because there, it worked. Forcing the scan mode to interlaced every time I tune to a channel is unacceptable. Until the broadcasters fix the headers then they shouldn't be used for this.

comment:6 Changed 14 years ago by Isaac Richards

Priority: majorminor
Resolution: invalid
Severity: mediumlow
Status: reopenedclosed

comment:7 Changed 13 years ago by anonymous

Resolution: invalid
Status: closedreopened

This is still a problem, probably due to the fact that the ticket was closed without a solution... Anyone?

comment:8 Changed 13 years ago by danielk

Resolution: wontfix
Status: reopenedclosed

The solution is to call the broadcaster on the phone and ask them to send an non-corrupt video stream. There is no general way for MythTV to detect interlacing when the broadcaster says the frame is progressive; we don't have a dedicated DSP to play with on a general purpose CPU like you do in the fanciest digital TV sets. If you write a fix for this based on partial decode and followed by a quick video processing stage, please reopen the ticket. Otherwise this is a feature request without a patch.

comment:9 Changed 13 years ago by greend139@…

Just curious if there is any way the user could override the de-interlacing autodetect on a per channel basis? Maybe manually set a key in the database like the use XvMC on HD only patch for 0.20.2? I only have this problem on two of my channels, and it would be nice if it were possible to just override the auto-detect feature on those 2 channels. It works great on all the rest of my channels (HD and SD), so thanks for all the hard work devs.

comment:10 Changed 13 years ago by anonymous

I haven't tested it yet, however it looks like profiles in 0.21 will allow for what you want to do.

Note: See TracTickets for help on using tickets.