Opened 14 years ago

Closed 14 years ago

#243 closed defect (fixed)

"Watch recordings" menu segfault

Reported by: torbjorn.jansson@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

since the old bugzilla seems to be removed, i've moved one of my old bugs over to trac. this bug used to be bug 300 in bugzilla.

if i select the "Watch recordings" menu and then quickly pres another key, like right arrow, the frontend segfaults. this have to be done before the watch recordings screen is fully shown (it takes a few seconds from selecting the "Watch recordings" menu to when its shown)

i can reproduce this all the time.

Attachments (1)

watch-recording-segfault.txt (1.5 KB) - added by torbjorn.jansson@… 14 years ago.
backtrace of segfault

Download all attachments as: .zip

Change History (6)

comment:1 Changed 14 years ago by Isaac Richards

Resolution: worksforme
Status: newclosed

Can't reproduce, you'll need to get a backtrace.

Changed 14 years ago by torbjorn.jansson@…

backtrace of segfault

comment:2 Changed 14 years ago by torbjorn.jansson@…

Resolution: worksforme
Status: closedreopened

i've attached a backtrace of the segfault.

comment:3 Changed 14 years ago by Isaac Richards

Resolution: fixed
Status: reopenedclosed

(In [7123]) Disable keypresses (except esc) when we're not connected to the backend. Should fix #243.

comment:4 Changed 14 years ago by Anduin Withers <awithers@…>

Resolution: fixed
Status: closedreopened

curitem can still be NULL in PlaybackBox::cursorRight() (same crash)

comment:5 Changed 14 years ago by Isaac Richards

Resolution: fixed
Status: reopenedclosed

(In [7127]) Fix #243 again.

Note: See TracTickets for help on using tickets.