Opened 14 years ago

Closed 14 years ago

#245 closed defect (fixed)

Need to use smaller DummyDTVStream resolution for the Epia M10000

Reported by: danielk Owned by: danielk
Priority: minor Milestone: 0.19
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Isaac Richards)

This is a problem that Torbjörn Jansson ran into...

>I'm having some problems with livetv too recently.
>I use an epia m10000 as frontend and recently the built in mpeg2 hw 
>decoder is not used when watching livetv.
>With recorded shows hw mpeg2 decoding works (low cpu usage, 
>black and white osd)
>
>And i'm geting stuff like this in the frontend log:
>---
>2005-08-20 22:49:56.658 Could not open XvMC port...
>
>                        You may wish to verify that your DISPLAY
>                        environment variable does not use an external
>                        network connection.
>
>                        You may also wish to verify that
>                        /etc/X11/XvMCConfig contains the correct
>                        vendor's XvMC library.
>
>2005-08-20 22:49:56.661 AVFD: Opened codec 0xb3763d30, id(MPEG2VIDEO)
>type(Video)
>2005-08-20 22:49:56.662 AVFD: Opened codec 0xb5d5b710, id(MP3) type(Audio)
>2005-08-20 22:49:56.714 AvFormatDecoder: Video has changed from 0x0 to
>720x576.

Attachments (1)

mythfrontend.log.bz2 (20.2 KB) - added by torbjorn.jansson@… 14 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 14 years ago by Isaac Richards

Description: modified (diff)

comment:2 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [7102]) Fixes #245.

This adds various blank dummy streams and uses a lower resolution stream for XvMC-VLD output.

This also adds a script mkdummyts.sh which should allow theme makers to generate DummyDTVRecorder compatible streams from images without having to know how all the parameters needed by ppmtoy4m, mpeg2enc, and vlc to generate MPEG-TS streams.

comment:3 Changed 14 years ago by torbjorn.jansson@…

Resolution: fixed
Status: closedreopened

i'm not so sure this problem is fixed, i still get stuff like:

2005-08-22 21:21:30.156 Prebuffer wait timed out 10 times.
2005-08-22 21:21:31.800 SyncPositionMap liveTV, from Encoder: 4 entries
2005-08-22 21:21:32.973 prebuffering pause
2005-08-22 21:21:34.516 Prebuffer wait timed out 10 times.
2005-08-22 21:21:35.826 prebuffering pause
2005-08-22 21:21:36.954 prebuffering pause
2005-08-22 21:21:38.089 prebuffering pause
2005-08-22 21:21:39.229 prebuffering pause
2005-08-22 21:21:40.445 prebuffering pause
2005-08-22 21:21:41.667 prebuffering pause
2005-08-22 21:21:42.189 Could not open XvMC port...

                        You may wish to verify that your DISPLAY
                        environment variable does not use an external
                        network connection.

                        You may also wish to verify that
                        /etc/X11/XvMCConfig contains the correct
                        vendor's XvMC library.

2005-08-22 21:21:42.201 AVFD: Opened codec 0x82f68a0, id(MPEG2VIDEO) type(Video)
2005-08-22 21:21:42.439 AVFD: Opened codec 0x83195c0, id(MP3) type(Audio)
2005-08-22 21:21:42.485 AvFormatDecoder: Video has changed from 0x0 to 720x576.
2005-08-22 21:21:43.402 Prebuffer wait timed out 10 times.
2005-08-22 21:21:45.090 Opening audio device '/dev/dsp'.
2005-08-22 21:21:45.090 Opening OSS audio device '/dev/dsp'.
2005-08-22 21:21:45.383 Prebuffer wait timed out 10 times.

when i start livetv i always end up at my analog card first, when i press Y the first time to switch to my dvb card, the first time i do this the screen stays black for maybe 30 seconds or so and then i'm back at the menu. second try it takes a while when switching to the dvb card but this time it works but no hw decoding.

comment:4 Changed 14 years ago by danielk

Hmmm, this is caused by something else then. Can you send me the log with "-v channel,playback,siparser" ? If I can't see the problem from that you might have to find the actual commit that caused the breakage.

Changed 14 years ago by torbjorn.jansson@…

Attachment: mythfrontend.log.bz2 added

comment:5 Changed 14 years ago by torbjorn.jansson@…

i've attached the log from the frontend with the options you wanted. note that the log contains two starts of livetv, the first one failed and it ends at the line

2005-08-22 22:22:35.025 LiveTV not successfully started

the resolution i'm using for X is 720x576 since that's what is needed for the nointerlace mode of the unichrome drivers (=good picture)

comment:6 Changed 14 years ago by danielk

Are you running a seperate frontend and backend? I queried the 'UseXvMCVld' on the backend, which of course can be different from the backend... Try setting 'UseXvMCVld' in the settings for the backend. Tell me if the frontend works at that point.

comment:7 Changed 14 years ago by torbjorn.jansson@…

yes, i'm running a separate frontend and backend. since my backend don't have vld support there is no gui for it, so i did: INSERT INTO settings (value,data,hostname) VALUES ('UseXvMcVld?','1','hostname-of-backend') but still no hw decoding.

comment:8 Changed 14 years ago by danielk

Resolution: fixed
Status: reopenedclosed

(In [7121]) Fixes #245.

This fix detects whether you are using an HDTV or DVB w/ATSC backend. It uses a 1920x1088 stream if you do and a 720x576 stream otherwise.

Torbjorn, if this doesn't fix it I'm going to need another log w/""-v channel,playback,siparser". Just e-mail it to me or the mailing list, I think your problem may have some other cause than this bug.

Note: See TracTickets for help on using tickets.