Opened 13 years ago

Closed 12 years ago

#2456 closed defect (fixed)

mythweb shows wrong airdate for movies

Reported by: ajlill@… Owned by: stuartm
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

If a movie is part of an active recording schedule, mythweb shows the date from starttime rather than the airdate from the program table. If it's not part of an active schedule, the correct data is shown.

Attachments (1)

Screenshot1.png (40.3 KB) - added by ajlill@… 13 years ago.
Screenshot of wonky movies

Download all attachments as: .zip

Change History (11)

comment:1 Changed 13 years ago by xris

I'm not sure what you mean. Can you attach a screenshot?

Changed 13 years ago by ajlill@…

Attachment: Screenshot1.png added

Screenshot of wonky movies

comment:2 Changed 13 years ago by ajlill@…

The movies on channels 303-305 are covered by a custom rule to record all movies on those channels. When you mouse over them it claims the original air date is 2006-10-03, which is the day I'm looking at. The movies on the other channels are not part of a rule. They show the correct year.

comment:3 Changed 13 years ago by xris

Owner: changed from xris to Isaac Richards

Isaac, I just confirmed that this is definitely happening, and that the data I get is incorrect coming from the backend into mythweb (index id 37 from a backend program info record).

I'll be putting a workaround into mythweb shortly, but someone should look into why the backend is sending the starttime in the airdate field.

comment:4 Changed 13 years ago by xris

Component: mythwebmythtv

comment:5 Changed 13 years ago by xris

(In [11668]) re #2456, merge values from the original object regardless of whether or not the data is already set. This should fix the airdate display issues for pending movie recordings. Hopefully it won't cause any new problems.

comment:6 in reply to:  5 Changed 13 years ago by otto at kolsi dot fi

Replying to xris:

(In [11668]) re #2456, merge values from the original object regardless of whether or not the data is already set. This should fix the airdate display issues for pending movie recordings. Hopefully it won't cause any new problems.

This change unfortunately brakes the program listings page for me. Now the scheduled recordings are no-longer marked with the green line.. so there is no way to see what programs will be recorded, all look the same.

comment:7 Changed 13 years ago by xris

(In [11680]) revert [11668] and add a specific override for airdate until a better solution can be found. re #2456

comment:8 Changed 13 years ago by Janne Grunau

Version: 0.20head

comment:9 Changed 13 years ago by stuartm

Milestone: unknown0.21
Owner: changed from Isaac Richards to stuartm

comment:10 Changed 12 years ago by stuartm

Resolution: fixed
Status: newclosed

Is this still an issue? I noticed that mythweb has changed and no longer displays any dates after the film name on the main guide page.

Looking back at the version of mythweb that was in use then, it contained a typo "has_airdate" instead of "hasairdate" which could have contributed to any problems. N.B. Trunk still contains this typo but at a different point now, but the part of the code in which it appears seems to be redundant anyway.

The airdate, for films and such, is stored in the recordedprogram table. Therefore it's possible that the fix I put in a couple of months back for joins between recorded and recordedprogram fixed this?

Xris, if this is still an issue then reopen the ticket and tell me exactly which table or query string to the backend is returning the incorrect information. I'll try to sort it, otherwise I'm closing this ticket for now.

Note: See TracTickets for help on using tickets.