Opened 14 years ago

Closed 13 years ago

#2464 closed patch (fixed)

Compile error when compiling with XvMC & g++ 3.3.6

Reported by: Mark.Buechler@… Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Get the following error with g++ 3.3.6:

XvMCSurfaceTypes.cpp: In member function `QString

XvMCSurfaceTypes::toString(Display*, long unsigned int) const':

XvMCSurfaceTypes.cpp:307: error: no matching function for call to `QString::

QString(std::basic_string<char, std::char_traits<char>, std::allocator<char>

)'

/opt/qt3/include/qstring.h:746: error: candidates are:

QString::QString(QStringData*, bool)

/opt/qt3/include/qstring.h:720: error: QString::QString(int,

bool)

/opt/qt3/include/qstring.h:406: error: QString::QString(const

char*)

/opt/qt3/include/qstring.h:404: error: QString::QString(const

QChar*, unsigned int)

/opt/qt3/include/qstring.h:403: error: QString::QString(const

QByteArray&)

/opt/qt3/include/qstring.h:402: error: QString::QString(const

QString&)

/opt/qt3/include/qstring.h:401: error: QString::QString(QChar) /opt/qt3/include/qstring.h:838: error: QString::QString() XvMCSurfaceTypes.cpp: In static member function `static QString

XvMCSurfaceTypes::XvMCDescription(Display*)':

XvMCSurfaceTypes.cpp:379: error: no matching function for call to `QString::

QString(std::basic_string<char, std::char_traits<char>, std::allocator<char>

)'

/opt/qt3/include/qstring.h:746: error: candidates are:

QString::QString(QStringData*, bool)

/opt/qt3/include/qstring.h:720: error: QString::QString(int,

bool)

/opt/qt3/include/qstring.h:406: error: QString::QString(const

char*)

/opt/qt3/include/qstring.h:404: error: QString::QString(const

QChar*, unsigned int)

/opt/qt3/include/qstring.h:403: error: QString::QString(const

QByteArray&)

/opt/qt3/include/qstring.h:402: error: QString::QString(const

QString&)

/opt/qt3/include/qstring.h:401: error: QString::QString(QChar) /opt/qt3/include/qstring.h:838: error: QString::QString() make[2]: * [XvMCSurfaceTypes.o] Error 1 make[2]: Leaving directory `/usr/src/mythtv.11259/mythtv/libs/libmythtv' make[1]: * [sub-libmythtv] Error 2 make[1]: Leaving directory `/usr/src/mythtv.11259/mythtv/libs' make: * [sub-libs] Error 2 pc4:/usr/src/mythtv.11259/mythtv#

Attachments (1)

patch.diff (570 bytes) - added by Mark.Buechler@… 14 years ago.
The patch..

Download all attachments as: .zip

Change History (5)

Changed 14 years ago by Mark.Buechler@…

Attachment: patch.diff added

The patch..

comment:1 Changed 14 years ago by danielk

Owner: changed from Isaac Richards to danielk

comment:2 Changed 14 years ago by Isaac Richards

Resolution: fixed
Status: newclosed

(In [11315]) Patch to fix compile error in XvMCSurfaceTypes.cpp.

Closes #2464.

comment:3 Changed 13 years ago by dcottingham00@…

Resolution: fixed
Status: closednew

This patch didn't get into the 0.20.2 release, so the problem is back.

XvMCSurfaceTypes.cpp in 0.20.2 is identical to that in 0.20, and so has the problem reported above.

comment:4 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

Fixed in head, we're not fixing 0.20 specific problems anymore..

Note: See TracTickets for help on using tickets.