Opened 13 years ago

Closed 11 years ago

#2493 closed defect (fixed)

loosing communication with backend

Reported by: ajlill@… Owned by: Isaac Richards
Priority: minor Milestone: 0.21
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

At least once a day my frontends lock up because they can't communicate with the backend, usually overnight when they are idle and sitting in the watch recordings screen. Also, mythfilldatabase has about a 1 in 4 chance of not being able to talk to the backend to trigger a reschedule.

I've attached 3 traces, one frontend trace with -vall, one with -vimportant and a backend trace with -vall,nojobqueue,noschedule,nocomflag,nodatabase. The short frontend trace corresponds to the backend trace, the long trace with an earlier incident.

mythbackend version: 0.20.20060828-3 www.mythtv.org const char *myth_source_version = "11277M";

Attachments (4)

baskend-full (13.4 KB) - added by ajlill@… 13 years ago.
Full trace
frontend-full (14.0 KB) - added by ajlill@… 13 years ago.
frontend-short (320 bytes) - added by ajlill@… 13 years ago.
timeout.patch (5.9 KB) - added by Tony Lill <ajlill@…> 12 years ago.
Patch to speed up QUERY_RECORDINGS and avoid MythSocket? timeout

Download all attachments as: .zip

Change History (9)

Changed 13 years ago by ajlill@…

Attachment: baskend-full added

Full trace

Changed 13 years ago by ajlill@…

Attachment: frontend-full added

Changed 13 years ago by ajlill@…

Attachment: frontend-short added

comment:1 Changed 13 years ago by Isaac Richards

Resolution: worksforme
Status: newclosed

Allright - what I'd like you to do is run the frontend (or mythfilldb) in gdb and set a breakpoint for mythsocket.cpp:239 (that's the 'Error, invalid string list' message). When that triggers, get a backtrace of things at that point, and attach here, and please reopen the ticket.

comment:2 Changed 13 years ago by ajlill@…

Resolution: worksforme
Status: closedreopened

After some more debugging, I found the problem was MythSocket? was timing out. I doubled the timeouts in mythsocket, and the problem has pretty much gone away, except, sometimes, when I delete and allow re-record. That's probably due to the extra work done when it re-schedules. I think if I double them again, that should get it.

I think once you build up around 1000 recordings, you'll be able to reproduce it too. Maybe I should change the summary for this ticket to "Mythtv doesn't scale"!

comment:3 Changed 12 years ago by paulh

Any chance you can get the backtrace that Isaac asked for so we can maybe get this fixed properly?

comment:4 Changed 12 years ago by Tony Lill <ajlill@…>

Sorry, but since I fixed the problems with QUERY_RECORDINGS taking forever, the problem hasn't re-occured. Since the issues with this have supposedly been fixed in 0.21, it's unlikly you'll see a fix before then. I'll attach my patch for 0.20, if there's any interest.

Changed 12 years ago by Tony Lill <ajlill@…>

Attachment: timeout.patch added

Patch to speed up QUERY_RECORDINGS and avoid MythSocket? timeout

comment:5 Changed 11 years ago by stuartm

Milestone: unknown0.21
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.