Opened 13 years ago

Closed 11 years ago

Last modified 11 years ago

#2502 closed patch (fixed)

Fix legacy switch support with diseqc tree

Reported by: nooneimprt4nt@… Owned by: danielk
Priority: minor Milestone: 0.20
Component: dvb Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This patch will fix legacy switch support (specifically sw42 and sw64, sw21 works ok) in SVN head. The problem is that, similar to a commited switch, the sw42 and sw64 need to be snet commands when the polarity changes.

Attachments (2)

legacy.diff (723 bytes) - added by nooneimprt4nt@… 13 years ago.
legacy_switch_h_fix.diff (894 bytes) - added by blake.zero@… 12 years ago.
possible fix to scan H transponders with SW21

Download all attachments as: .zip

Change History (10)

Changed 13 years ago by nooneimprt4nt@…

Attachment: legacy.diff added

comment:1 Changed 13 years ago by anonymous

Component: mythtvdvb
Owner: changed from Isaac Richards to danielk

comment:2 Changed 13 years ago by danielk

(In [11352]) Refs #2502. Fixes the SW42 and SW64 switch support in SVN. Support for these pre-DiSEqC switches was broken by the new DiSEqC code, these switches need to be notified of polarity changes.

Keeping open for backport to 0.20-fixes.

comment:3 Changed 13 years ago by danielk

Milestone: unknown0.20

comment:4 Changed 13 years ago by danielk

Type: defectpatch
Version: head0.20

comment:5 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

(In [11426]) Fixes #2502. Fixes the DiSEqC switch code for the SW42 and SW64 switches.

These are not true DiSEqC switches, but rather pre-DiSEqC legacy switches which require notification of polarity changes, this change makes MythTV notify these switches of these polarity changes.

We were doing this in 0.19, but this hack got lost in the DiSEqC rewrite.

comment:6 Changed 12 years ago by blake.zero@…

Resolution: fixed
Status: closednew

I think legacy switch support is broken in trunk, I can't scan or lock horizontal transponders with a legacy SW21. The problem seems to be a missing OR 0x80 for horizontal transponders after the command is selected from the command table. If I add this I can lock horizontal transponders. I can't test the other legacy switches so I don't know if they are working without this fix, but looking at the original patch it seems that they needs it too. See #1037 for original patch.

Changed 12 years ago by blake.zero@…

Attachment: legacy_switch_h_fix.diff added

possible fix to scan H transponders with SW21

comment:7 Changed 11 years ago by danielk

Resolution: fixed
Status: newclosed

Blake, please open a new ticket. Whatever the problem you are seeing is it is not the problem described in the ticket last year. Also the patch you attached doesn't compile for a number of reasons, please test any future patches...

comment:8 Changed 11 years ago by blake0 <blake.zero@…>

Sorry for using the wrong ticket, I had already open new ticket #4493, and the patch was also corrected a couple of days ago. Thanks.

Note: See TracTickets for help on using tickets.