Opened 14 years ago

Closed 14 years ago

#2506 closed defect (fixed)

Changeset 11327 causes dropped frames/prebuffering pauses when OSD is drawn.

Reported by: perveilerj@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After updating to r11358 I started getting prebuffering pauses after seeking. A little more debugging showed that the real problem was putting the OSD on the screen. Using r11358 with r11327 backed out causes the problem to go away.

I don't see the pauses with 480i content, but I do with both 720p and 1080i (720p more frequently, oddly). I use the standard decoder and OpenGL Video VSync on a 3.0 GHz P4 w/HT and the Chroma OSD.

Attached logfile is with -v playback. I start watching a pre-recorded, let it run fine for a couple of seconds, push the info button to get the OSD, and the pauses and frame drops start up. The OSD then goes away and a second or so later things are OK again.

Let me know if anything more is needed.

--Jack

Attachments (1)

mythfrontend.log (62.8 KB) - added by perveilerj@… 14 years ago.
frontend log with -v playback

Download all attachments as: .zip

Change History (2)

Changed 14 years ago by perveilerj@…

Attachment: mythfrontend.log added

frontend log with -v playback

comment:1 Changed 14 years ago by Isaac Richards

Resolution: fixed
Status: newclosed

(In [11364]) Remove unnecessary part of r11327 that was adding too much CPU usage.

Should fix #2506.

Note: See TracTickets for help on using tickets.