Opened 13 years ago

Closed 13 years ago

#2510 closed defect (fixed)

Problem with Internal DVD Player Seek Amount

Reported by: fracmak Owned by: skamithi
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

This is kinda a wacky bug I've been experiencing with the dvd player. I have the rewind amount set for 5 seconds, but the dvd player doesn't always follow that setting. I've been trying to track down exactly what's causing it. I've attached a mythfrontend -v playback log snippet where I asked it to rewind 5 seconds, but it instead did a rewind of 20 seconds. I'd been playing the dvd for about 5 minutes before rewinding, it also went through a title change (tv show -> play all -> transition from one title/episode to the next).

Attachments (2)

DVDSeekProblem.txt (4.1 KB) - added by fracmak 13 years ago.
ticket_2510.diff (687 bytes) - added by skamithi 13 years ago.

Download all attachments as: .zip

Change History (14)

Changed 13 years ago by fracmak

Attachment: DVDSeekProblem.txt added

comment:1 Changed 13 years ago by fracmak

this is supposed to be assigned to "stanley kamithi" per mythtv-users

comment:2 Changed 13 years ago by Anduin Withers

Owner: changed from Anduin Withers to skamithi

comment:3 Changed 13 years ago by skamithi

Component: mythdvdmythtv

comment:4 Changed 13 years ago by skamithi

Status: newassigned

comment:5 Changed 13 years ago by skamithi

i believe i've reproduced the issue. attaching patch shortly. pls test patch.

Changed 13 years ago by skamithi

Attachment: ticket_2510.diff added

comment:6 Changed 13 years ago by skamithi

Milestone: unknown0.21

comment:7 Changed 13 years ago by skamithi

the nvp/decoder framesplayed counter is often way off what the dvd frames played calculation produces.

sync the framesplayed counter to what the dvd framesplayed calculation produces before skipping forward or skipping behind. This should produce a consistent skip ffw and skip rew experience.

comment:8 Changed 13 years ago by fracmak

I applied the patch and I'm still experiencing the same problem.

comment:9 Changed 13 years ago by skamithi

i'll write a debug patch for you. i'm not sure then what the problem is.

comment:10 Changed 13 years ago by fracmak

after playing with it a little more, seeking seem to be better, it isn't wildly off by 30+ seconds, but it still can be off by anywhere from 3 to 6 seconds. The best way I found to test it was to basically hit the fast forward (30 seconds) repeatedly, half the time it'll fast forward 30 seconds exactly, half the time it'll fast forward anywhere between 36 seconds and 27 seconds.

comment:11 Changed 13 years ago by skamithi

since dvdnav_time_search in the dvdnav api is currently not implemented, i use a calculation to get the next seek position. it is not a precise calculation so it may be off, like you've seen.

since its not too far off, i'll just commit what is there and leave the implemenation of dvdnav_time_search function to someone else. whenever that's done, or if someone cares enough about this and comes up with a better way, then, of cause, the code will be changed.

comment:12 Changed 13 years ago by skamithi

Resolution: fixed
Status: assignedclosed

(In [11468]) Closes #2510. internal dvd player. makes jumps using seekrwnd, and seekfwd a little more predictable. its not precise but better then it was before.

Note: See TracTickets for help on using tickets.