Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2512 closed defect (worksforme)

Live tv studders little bit

Reported by: chris@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: ikke@… Ticket locked: no

Description

After the update from 0.19 to 0.20 live tv startet to studder a little bit. You see it good, while watching a news channel with this scrolling texts. I changed nothing else, only updated mythtv to 0.20 rev 11281. The mythtv playback settings, the nvidia driver settings are all the same. The studder can be stopped, if live tv is paused for a few seconds.

In my frontend.log, there are the following messages again and again, that could have something to do with that studder:

  • NVP: Waiting for prebuffer.. 0 AAAAAAAAAAaAALAAAuAAAAAAAAAAAAA
  • WriteAudio?: buffer underrun
  • AO: dropping back audio_buffer_unused

I attach the complete frontend.log.

Some system info:

  • Mythtv: 0.20 rev 11281. Playback settings: OpenGL Sync=on, Deint: Bob, UseVideoAsTimebase?=on, big audio buffer=on, decoder=Default
  • OS: Gentoo Linux (the whole system 64bit compiled)
  • Processor: AMD Athlon 64 3500
  • Ram: 1GB Kingston HyperX
  • Video source: 2x DVB-S (Hauppauge Nova-S plus)
  • Graphic card: Nvidia GF 6600. Driver version: 1.0.8762-r1, Special driver settings: SyncToVBlank=on, XVideoTextureSyncToVBlank=off, XVideoBlitterSyncToVBlank=on

Attachments (1)

mythfrontend.log (16.9 KB) - added by chris@… 13 years ago.
my mythfrontend log

Download all attachments as: .zip

Change History (9)

Changed 13 years ago by chris@…

Attachment: mythfrontend.log added

my mythfrontend log

comment:1 Changed 13 years ago by anonymous

Cc: ikke@… added

comment:2 Changed 13 years ago by anonymous

I am also seeing this. Was fine before 0.19 ... now stutters at start of playback and during playback. With and without xvmc.

comment:3 Changed 13 years ago by danielk

Resolution: invalid
Status: newclosed

User error, all of these nVidia driver options should be off:

SyncToVBlank=on, XVideoTextureSyncToVBlank=off, XVideoBlitterSyncToVBlank=on

See the XvMC article in the wiki, these options still need to be off for plain XVideo with the latest nVidia drivers and 6xxx or later hardware.

comment:4 Changed 13 years ago by chris@…

Resolution: invalid
Status: closedreopened

I tried the suggested nvidia driver settings. I turned all three off, but with the same studder effects I wrote about. It also doesn't matter, if I turn XvMC on or off. While watching LiveTV, CPU usage of mythfrontend is 15%-18% most of the time with every setting I tried. If the studder was not playback related, it could be solved every time by pausing LiveTV for a few seconds. I forgot to mention earlier, that the effects also never occur while watching recordings. So I think neither my mythtv playback settings nor my nvidia settings are wrong. So cause the problem is still there, I reopen the ticket.

comment:5 Changed 13 years ago by anonymous

I have this issue as well. If I hit pause the video for a few seconds the studdering will disapear until the next channel change.

comment:6 Changed 13 years ago by danielk

Resolution: worksforme
Status: reopenedclosed

Works here on a Pentium 2.8 Ghz.

Please ask for help in the MythTV users mailing list.

comment:7 Changed 13 years ago by dfleming@…

I'm experiencing this problem with my PVR-350's. It was okay with v.19, but now live tv studders.

comment:8 Changed 13 years ago by anonymous

This is a "me too". Latest mythtv and live tv studders. This is totally unrelated to XvMC (which I am not using). I guess this has something to do with the fact that live tv gets played back by reading a file which is at the same time written by mythtv backend. So I guess it's got something to do with the buffering or timing. Maybe the filesystem (and kernel version) plays a role here too.

This is definitely a bug with mythtv which should get investigated and fixed. Reminds me- watching live tv (a few seconds behind) results in a short break when a file switch happens. That's pretty annoying too and I don't know if this is intended.

Note: See TracTickets for help on using tickets.