Opened 13 years ago

Closed 13 years ago

#2520 closed defect (duplicate)

Bell ExpressVu EIT processed with incorrect character encoding

Reported by: chhamilton@… Owned by: danielk
Priority: minor Milestone: unknown
Component: dvb Version: 0.20
Severity: medium Keywords: dvb eit encoding bev bell expressvu
Cc: Ticket locked: no

Description

As of version 0.20, MythTV incorrectly handles EIT information for Bell ExpressVu?. The problem has to do with MythTV treating the EIT as fully ETSI compliant. Since string data is not preceded with any encoding information, it is incorrectly assumed to be in an ISO 6937 encoding, where is actually in an ISO 8859-1 encoding. This causes incorrect guide information to be extracted for all of the French stations (which often use accented characters in their descriptions and titles).

A simple fix has been implemented in the spirit of the Pro7Sat fix. The impact is kept localized to the ""EITHelper::AddEIT(const DVBEventInformation *eit) function"". The idea is simply to wrap the text strings with the appropriate encoding header, so that ""dvb_decode_text"" will use ISO 8859-1 instead. A patch has been provided, taken against the 0.20-fixes branch at revision

Change History (2)

comment:1 Changed 13 years ago by chhamilton@…

Sorry, but somehow managed to hit submit twice. The final ticket with attached fix is to be found at http://cvs.mythtv.org/trac/ticket/2521 as ticket # 2521. Fell free to delete this one!

comment:2 Changed 13 years ago by danielk

Resolution: duplicate
Status: newclosed

Duplicate of more complete #2521.

Note: See TracTickets for help on using tickets.