Opened 13 years ago

Closed 13 years ago

#2529 closed defect (invalid)

Poor playback with Internal player

Reported by: anonymous Owned by: skamithi
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi!

I have been troubleshooting the internal player for dvd among other video sources, but can´t get good video playback. The video seems to be running with half the framerate sometimes and stutters severe when new dvd subtiltes is displayed.

Here is somethings i´ve tried so far. 1 recompiled the kernel 2 recompiled myth 3 enable/disable spdif 4 oss emulation/ALSA:default 5 standard decoder/libmpeg2 6 dienterlace on/off 7 dvd from image and from dvd-rom 8 modeline exactly 50 hz 9 realtime priority on/off 10 aggresive sound buffering on/off 11 extra sound buffering on/off 12 use video as timebase on/off 13 opengl vsync on/off 14 rtc timing method with 1024 hz 15 hdparm disk test for both dvd and hdd 16 turned off all special settings for nvidia driver (nvidia-settings)

Hardware: Gentoo running 2.16.17-r4 kernel Mythtv 0.20+fixes Pentium4 prescott 2.4Gh 512 mb ddram 120gb symsung v120 hdd Nvidia geforce mx440 soundblaster live! value

I dont know what logfiles is relevant?, nothing out of the ordenary displays in the mythfrontend -v playback log.

Best regards Staffan

Attachments (1)

frontend-playback.log (91.0 KB) - added by anonymous 13 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 13 years ago by Anduin Withers

Component: mythvideomythtv
Owner: changed from Anduin Withers to skamithi

comment:2 Changed 13 years ago by skamithi

attach mythfrontend -v playback (even if u think its not useful). need it from the time you start mythfrontend to , the time + 1 minute, after you experience the poor playback performance.

Changed 13 years ago by anonymous

Attachment: frontend-playback.log added

comment:3 Changed 13 years ago by scifi@…

Hi again!

Here is the frontend -v playback log you asked for. The log is from The Big Lebowski region 2 dvd.

Please let me know if you need more logs or detailes

Best regards Staffan

comment:4 Changed 13 years ago by skamithi

i run gentoo 2.6.16 with a p4 (2.4ghz) and used to have a mx440 and it worked perfectly. i think something else other then myth is causing this.

have you tried not running myth as root ?

comment:5 Changed 13 years ago by scifi@…

Ok

It might be something wrong with my system but i cant figure out what.

The conclusion that i have come up with is that the video and audio is running a little bit to fast, and when the first subtitle gets displayd both the video and audio resyncs to the sub.

I´ve tried some diffrent modelines today but not able to fix this, also your suggestion of running mythfrontend is none root user did´nt solve it.

Maye i ask what other type of hardware you have? like soundcard etc...

comment:6 Changed 13 years ago by skamithi

pls see if [11670] resolves your issue.

comment:7 Changed 13 years ago by skamithi

typo. pls see if [11607] resolves your issue.

comment:8 Changed 13 years ago by skamithi

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.