Opened 13 years ago

Closed 13 years ago

#2531 closed defect (fixed)

mythreplex recent regression in svn

Reported by: gnome42@… Owned by: Geoffrey Hausheer
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

mythreplex recently stopped working on a file it previously had processed successfully. I have used mytharchive to create a dvd with this file on it at around version [11285].

This is the tail of the mythreplex log

Wrong audio frame size: 2328
audio PTS inconsistent:  0:03:44.736  0:00:21.120 diff:  0:00:44.543 
video PTS inconsistent:  0:03:45.143  0:03:45.143  0:00:29.881  0:00:29.696  diff:  0:00:36.188 
video DTS inconsistent:  0:03:45.109  0:03:45.109  0:00:29.547  0:00:29.362 diff:  0:00:36.489 
Wrong audio frame size: 1746
audio PTS inconsistent:  0:03:45.056  0:00:21.184 diff:  0:00:44.799 

[ .. many repeats of the above .. ]

Error: THIS IS AN MPEG1 FILE

and it errors out here :/

Change History (3)

comment:1 Changed 13 years ago by gnome42@…

Ok, after a bunch of recompiles I've nailed it down to changeset [11411] the conversion from a recursive call to a loop in mythtranscode/replex/pes.c. Backing out that changeset from head fixes the issue and I can once again create a dvd with that file.

Regards,

Shane

comment:2 Changed 13 years ago by Geoffrey Hausheer

Owner: changed from Isaac Richards to Geoffrey Hausheer
Status: newassigned

comment:3 Changed 13 years ago by Geoffrey Hausheer

Resolution: fixed
Status: assignedclosed

(In [11456]) This hopefully fixes #2531 I can't reproduce the issue myself, but it is the only thing I could see that is wrong with the code. Let me know if it is still broken

Note: See TracTickets for help on using tickets.