Opened 14 years ago

Closed 14 years ago

#2558 closed defect (fixed)

SIGABRT in Mythvideo (with internal player)

Reported by: bhuffman@… Owned by: skamithi
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When playing older VOB files ripped from DVD, I can reproduce a crash (SIGABRT) when playing using the internal player. This can take several iterations before the crash, but so far I've been able to reproduce by going into the movie, hitting ff, then hitting "exit" and then "exit" again to exit the video. A full backtrace is attached.

Attachments (1)

gdb.txt (35.0 KB) - added by bhuffman@… 14 years ago.

Download all attachments as: .zip

Change History (5)

Changed 14 years ago by bhuffman@…

Attachment: gdb.txt added

comment:1 Changed 14 years ago by Anduin Withers

Component: mythvideomythtv
Owner: changed from Anduin Withers to Isaac Richards

comment:2 Changed 14 years ago by skamithi

Owner: changed from Isaac Richards to skamithi
Status: newassigned

Please see if changeset [11607] resolves your issue. changes made to the dvd seek code prevent threads from accessing the seek function at the same time.

comment:3 Changed 14 years ago by bhuffman@…

After the latest SVN update I'm unable to reproduce the problem. So, either it's your patch or the fact that I needed to rebuild the seektables on my VOB files. :-) I'd say you can close this. Thanks -b

comment:4 Changed 14 years ago by skamithi

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.